Project

General

Profile

Bug #27241

Duplicate content views with same filter criteria in a CCV doesn't show full packages count

Added by Ian Ballou 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1722968

Description of problem:
Creating 2 content views with the same exclusion filter on a package and adding it to a CCV still applies the exclusion filter to the CCV.

Version-Release number of selected component (if applicable):
katello-3.12.0-0.5

How reproducible:
100%

Steps to Reproduce:
1. sync a repo (e.g. sat6tool7)
2. create a CV, attach the repo and apply a filter (e.g. exclude tracer-common)
3. create another CV with same filter.
4. publish the two CVs
5. create CCV containing those 2 CVs, and publish it
6. Check the CCV content in WebUI
7. Check the CCV content via yum / directly under /var/lib/pulp/published/yum/master/yum_distributor/<OrgID>-<CCVName>-Library-<repo-uuid> directory

Actual results:
6. 60 packages shown
7. 60 packages shown

Expected results:
Steps 6 and 7 should have the full package of 61.

Actual Results:
Steps 6 and 7 has 60 packages.

Additional info:
Please note that in sat6tool7, there's a total of 61 packages. When you publish a CCV with the 2 duplicate CV, there's a message that states:
"For the duplicate repositories, the packages in each Content View Version will combine regardless of the filters that were applied to the individual Content View Version."

Even though the message says "regardless of the filters that were applied", it seems the filters were still in effect. We either need to update the message or actually make sure that even duplicate CV with the same filters are taken into account to show the full number of packages.

Associated revisions

Revision 6a1f7b04 (diff)
Added by Ian Ballou 3 months ago

Fixes #27241 - duplicate content views & CCVs

History

#1 Updated by Ian Ballou 3 months ago

  • Subject changed from Duplicate content views with same filter criteria in a CCV doesn't show full packages count to Duplicate content views with same filter criteria in a CCV doesn't show full packages count

The expected result here is that the resulting composite content view will have the 60 packages. This is because a composite content view is a merger of two content view versions; there is no concept of filters there. The composite content view will have universal set of whatever is in the two merging content view versions.

With that said, the fix here will be to update the information message and remove the "regardless of the filters that were applied" part.

#2 Updated by Ian Ballou 3 months ago

  • Found in Releases Katello 3.12.0 added

#3 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8198 added

#4 Updated by Jonathon Turel 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.13.0

#5 Updated by Ian Ballou 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF