Project

General

Profile

Bug #27280

Unable to join a machine with bonded primary interface

Added by Nicki Clear over 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Foreman: 1.22.0
Katello: 3.12.0

Unable to join a machine using subscription manager with a bonded primary interface.

I get this error when using subscription-manager.

HTTP error (422 - Unknown): Validation failed: Attached to can’t be blank

I traced through the logs - I think it is an issue that it can’t tell what the slave ethernet devices are.

this is from the /var/log/foreman/production.log

2019-07-10T10:29:32 [I|app|a25781d5] Import facts for '<redacted system name>' completed. Added: 220, Updated: 0, Deleted 0 facts
2019-07-10T10:29:32 [I|aud|a25781d5] Nic::Managed (834) update event on mac , <redacted>
2019-07-10T10:29:32 [I|aud|a25781d5] Nic::Managed (834) update event on virtual false, true
2019-07-10T10:29:32 [I|aud|a25781d5] Nic::Managed (834) update event on identifier , bond0
2019-07-10T10:29:32 [W|app|a25781d5] Not queueing Nic::Managed: ["Attached to can't be blank"]
2019-07-10T10:29:32 [W|app|a25781d5] Not queueing Nic::Managed: ["Attached to can't be blank"]
2019-07-10T10:29:32 [W|app|a25781d5] Not queueing Nic::Managed: ["Attached to can't be blank"]

Related issues

Is duplicate of Foreman - Bug #26727: Bond interfaces as primary nic create invalid recordsClosed

History

#1 Updated by Andrew Kofink over 1 year ago

Could you please show us the list of facts from subscription-manager?

subscription-manager facts --list

Thanks!

#2 Updated by Andrew Kofink over 1 year ago

  • Status changed from New to Need more information

#3 Updated by Nicki Clear over 1 year ago

[root@amhraookdpc1 ~]# subscription-manager register --org=1-CAE --activationkey=cae-centos7
HTTP error (422 - Unknown): Validation failed: Attached to can't be blank
[root@amhraookdpc1 ~]# subscription-manager facts --list
cpu.core(s)_per_socket: 8
cpu.cpu(s): 32
cpu.cpu_socket(s): 2
cpu.thread(s)_per_core: 2
cpu.topology_source: kernel /sys cpu sibling lists
distribution.id: Core
distribution.name: CentOS Linux
distribution.version: 7
distribution.version.modifier: Unknown
dmi.baseboard.manufacturer: NetApp
dmi.baseboard.product_name: H300E
dmi.baseboard.serial_number: 221810002701
dmi.baseboard.version: 1.01
dmi.bios.address: 0xf0000
dmi.bios.bios_revision: 5.6
dmi.bios.relase_date: 07/10/2017
dmi.bios.rom_size: 16384 KB
dmi.bios.runtime_size: 64 KB
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: NA2.1
dmi.chassis.asset_tag: 111-03961+A0
dmi.chassis.boot-up_state: Safe
dmi.chassis.lock: Not Present
dmi.chassis.manufacturer: NetApp
dmi.chassis.power_supply_state: Safe
dmi.chassis.security_status: None
dmi.chassis.serial_number: 221811002798(A)
dmi.chassis.thermal_state: Safe
dmi.chassis.type: Other
dmi.chassis.version: 0123456789
dmi.connector.external_connector_type: None
dmi.connector.external_reference_designator: Not Specified
dmi.connector.internal_connector_type: Other
dmi.connector.internal_reference_designator: JSD1 - SATA DOM POWER
dmi.connector.port_type: Other
dmi.memory.array_handle: 0x001d
dmi.memory.assettag: P1-DIMMA2_AssetTag (date:17/50)
dmi.memory.bank_locator: P0_Node0_Channel0_Dimm1
dmi.memory.data_width: 64 bit
dmi.memory.error_correction_type: Multi-bit ECC
dmi.memory.error_information_handle: No Error
dmi.memory.form_factor: DIMM
dmi.memory.location: System Board Or Motherboard
dmi.memory.locator: P1-DIMMA2
dmi.memory.manufacturer: Samsung
dmi.memory.maximum_capacity: 768 GB
dmi.memory.part_number: M393A2K40CB1-CRC
dmi.memory.serial_number: 37BEBD99
dmi.memory.size: 16384 MB
dmi.memory.speed: 2400 MHz (0.4ns)
dmi.memory.total_width: 72 bit
dmi.memory.type: Unknown
dmi.memory.use: System Memory
dmi.meta.cpu_socket_count: 2
dmi.processor.asset_tag: Not Specified
dmi.processor.family: Xeon
dmi.processor.l1_cache_handle: 0x0052
dmi.processor.l2_cache_handle: 0x0053
dmi.processor.l3_cache_handle: 0x0054
dmi.processor.part_number: Not Specified
dmi.processor.serial_number: Not Specified
dmi.processor.socket_designation: CPU1
dmi.processor.status: Populated:Enabled
dmi.processor.type: Central Processor
dmi.processor.upgrade: Unknown
dmi.processor.version: Intel(R) Xeon(R) CPU E5-2620 v4 2.10GHz
dmi.processor.voltage: 1.8 V
dmi.slot.current_usage: Available
dmi.slot.designation: CPU1 SLOT1B PCI-E 3.0 X8
dmi.slot.slotlength: Short
dmi.slot.type:slotbuswidth: x8
dmi.slot.type:slottype: Unknown
dmi.system.family: Default string
dmi.system.manufacturer: NetApp
dmi.system.product_name: H300E
dmi.system.serial_number: 221810002701
dmi.system.sku_number: Default string
dmi.system.status: No errors detected
dmi.system.uuid: 00000000-0000-0000-0000-AC1F6B0F87CC
dmi.system.version: 0123456789
dmi.system.wake-up_type: Power Switch
lscpu.architecture: x86_64
lscpu.bogomips: 4199.71
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 8
lscpu.cpu(s): 32
lscpu.cpu_family: 6
lscpu.cpu_max_mhz: 3000.0000
lscpu.cpu_mhz: 2738.433
lscpu.cpu_min_mhz: 1200.0000
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb cat_l3 cdp_l3 intel_ppin intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm cqm rdt_a rdseed adx smap xsaveopt cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 256K
lscpu.l3_cache: 20480K
lscpu.model: 79
lscpu.model_name: Intel(R) Xeon(R) CPU E5-2620 v4
2.10GHz
lscpu.numa_node(s): 2
lscpu.numa_node0_cpu(s): 0-7,16-23
lscpu.numa_node1_cpu(s): 8-15,24-31
lscpu.on-line_cpu(s)_list: 0-31
lscpu.socket(s): 2
lscpu.stepping: 1
lscpu.thread(s)_per_core: 2
lscpu.vendor_id: GenuineIntel
lscpu.virtualization: VT-x
memory.memtotal: 395970560
memory.swaptotal: 0
net.interface.bond0.ipv4_address: 172.16.21.199
net.interface.bond0.ipv4_address_list: 172.16.21.199
net.interface.bond0.ipv4_broadcast: 172.16.21.255
net.interface.bond0.ipv4_broadcast_list: 172.16.21.255
net.interface.bond0.ipv4_netmask: 24
net.interface.bond0.ipv4_netmask_list: 24
net.interface.bond0.mac_address: AC:1F:6B:8D:4E:D1
net.interface.br0.mac_address: 3A:50:94:38:86:4B
net.interface.docker0.ipv4_address: 169.254.0.1
net.interface.docker0.ipv4_address_list: 169.254.0.1
net.interface.docker0.ipv4_broadcast: Unknown
net.interface.docker0.ipv4_broadcast_list: Unknown
net.interface.docker0.ipv4_netmask: 16
net.interface.docker0.ipv4_netmask_list: 16
net.interface.docker0.mac_address: 02:42:31:9C:1A:D5
net.interface.eth0.ipv4_address: 172.16.7.133
net.interface.eth0.ipv4_address_list: 172.16.7.133
net.interface.eth0.ipv4_broadcast: 172.16.7.255
net.interface.eth0.ipv4_broadcast_list: 172.16.7.255
net.interface.eth0.ipv4_netmask: 24
net.interface.eth0.ipv4_netmask_list: 24
net.interface.eth0.mac_address: AC:1F:6B:0F:87:CC
net.interface.eth1.ipv4_address: 172.16.7.8
net.interface.eth1.ipv4_address_list: 172.16.7.8
net.interface.eth1.ipv4_broadcast: 172.16.7.255
net.interface.eth1.ipv4_broadcast_list: 172.16.7.255
net.interface.eth1.ipv4_netmask: 24
net.interface.eth1.ipv4_netmask_list: 24
net.interface.eth1.mac_address: AC:1F:6B:0F:87:CD
net.interface.eth2.ipv4_address: 10.107.139.131
net.interface.eth2.ipv4_address_list: 10.107.139.131
net.interface.eth2.ipv4_broadcast: 10.107.139.255
net.interface.eth2.ipv4_broadcast_list: 10.107.139.255
net.interface.eth2.ipv4_netmask: 24
net.interface.eth2.ipv4_netmask_list: 24
net.interface.eth2.mac_address: AC:1F:6B:8D:4E:D0
net.interface.eth3.mac_address: AC:1F:6B:8D:4E:D1
net.interface.eth3.permanent_mac_address: AC:1F:6B:8D:4E:D1
net.interface.eth4.mac_address: AC:1F:6B:8D:4E:D1
net.interface.eth4.permanent_mac_address: AC:1F:6B:54:B2:02
net.interface.eth5.ipv4_address: 10.107.139.213
net.interface.eth5.ipv4_address_list: 10.107.139.213
net.interface.eth5.ipv4_broadcast: 10.107.139.255
net.interface.eth5.ipv4_broadcast_list: 10.107.139.255
net.interface.eth5.ipv4_netmask: 24
net.interface.eth5.ipv4_netmask_list: 24
net.interface.eth5.mac_address: AC:1F:6B:54:B2:03
net.interface.lo.ipv4_address: 127.0.0.1
net.interface.lo.ipv4_address_list: 127.0.0.1
net.interface.lo.ipv4_broadcast: Unknown
net.interface.lo.ipv4_broadcast_list: Unknown
net.interface.lo.ipv4_netmask: 8
net.interface.lo.ipv4_netmask_list: 8
net.interface.ovs-system.mac_address: 4A:52:1E:F3:4D:31
net.interface.tun0.ipv4_address: 10.129.2.1
net.interface.tun0.ipv4_address_list: 10.129.2.1
net.interface.tun0.ipv4_broadcast: 10.129.3.255
net.interface.tun0.ipv4_broadcast_list: 10.129.3.255
net.interface.tun0.ipv4_netmask: 23
net.interface.tun0.ipv4_netmask_list: 23
net.interface.tun0.mac_address: 02:E3:95:01:CE:05
net.interface.vxlan_sys_4789.mac_address: CA:61:64:ED:CB:C8
net.interface.vxlan_sys_4789.permanent_mac_address: Unknown
network.fqdn: amhraookdpc1<redacted>
network.hostname: amhraookdpc1
network.ipv4_address: 172.16.21.199
network.ipv6_address: ::1
nic.attached_to: eth4
proc_cpuinfo.common.address_sizes: 46 bits physical, 48 bits virtual
proc_cpuinfo.common.cache_alignment: 64
proc_cpuinfo.common.cache_size: 20480 KB
proc_cpuinfo.common.clflush_size: 64
proc_cpuinfo.common.cpu_cores: 8
proc_cpuinfo.common.cpu_family: 6
proc_cpuinfo.common.cpuid_level: 20
proc_cpuinfo.common.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb cat_l3 cdp_l3 intel_ppin intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm cqm rdt_a rdseed adx smap xsaveopt cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts
proc_cpuinfo.common.fpu: yes
proc_cpuinfo.common.fpu_exception: yes
proc_cpuinfo.common.microcode: 0xb000021
proc_cpuinfo.common.model: 79
proc_cpuinfo.common.model_name: Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz
proc_cpuinfo.common.power_management: Unknown
proc_cpuinfo.common.siblings: 16
proc_cpuinfo.common.stepping: 1
proc_cpuinfo.common.vendor_id: GenuineIntel
proc_cpuinfo.common.wp: yes
proc_stat.btime: 1563294253
system.certificate_version: 3.2
system.default_locale: en_US.UTF-8
uname.machine: x86_64
uname.nodename: amhraookdpc1
uname.release: 3.10.0-862.14.4.el7.x86_64
uname.sysname: Linux
uname.version: #1 SMP Wed Sep 26 15:12:11 UTC 2018
virt.host_type: Not Applicable
virt.is_guest: False
[root@amhraookdpc1 ~]#

#4 Updated by Nicki Clear over 1 year ago

This used to work on an older version of Katello, version 3.8. I have older clients that have bonded primary interfaces that I was able to join using that version.

#5 Updated by Jonathon Turel over 1 year ago

  • Status changed from Need more information to New

#6 Updated by Chris Roberts over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello Backlog

Moving to backlog until Nicki comes back with requested info

#7 Updated by Nicki Clear over 1 year ago

Chris,
What more information is needed? I provided the subscription-manager facts --list that Andrew wanted.

#8 Updated by James Jeffers over 1 year ago

  • Assignee set to James Jeffers

#9 Updated by James Jeffers over 1 year ago

  • Triaged changed from Yes to No
  • Target version deleted (Katello Backlog)
  • Project changed from Katello to Foreman
  • Found in Releases 1.22.0 added
  • Found in Releases deleted (Katello 3.12.0)
  • Fixed in Releases 1.24.0 added

This defect appears to have been fixed in Foreman 1.24 and is a duplicate of https://projects.theforeman.org/issues/26727.

I tested Foreman at commits before and after https://github.com/theforeman/foreman/commit/173b7f9c8af5ced2f59f5a3dc09b74da3ce09a95. Previously, a client with a bonded nic as primary interface could not register with Foreman/Katello. After the commit, the client could register, and the error was not seen.

#10 Updated by Tomer Brisker about 1 year ago

  • Status changed from New to Duplicate
  • Fixed in Releases deleted (1.24.0)

#11 Updated by Tomer Brisker about 1 year ago

  • Is duplicate of Bug #26727: Bond interfaces as primary nic create invalid records added

Also available in: Atom PDF