Project

General

Profile

Bug #27353

VMware Image based Provisioning fails with error- : Could not find virtual machine network interface matching <IP>

Added by Ondřej Ezr over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
-
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1731516

Description of problem:

Satellite 6.4
VSphere Version 6.7

Image based build fails with errors :
-----------------
019-06-19T09:35:35 [D|app|e0041] Processing task 'Query instance details for host.example.com' from 'Host::Managed Main'
2019-06-19T09:35:35 [D|app|e0041] Orchestration::Compute: Trying to match network interfaces from fog <Fog::Compute::Vsphere::Interfaces
server_id="500e25d1-8178-d44b-0974-ba04d811330b"
[
<Fog::Compute::Vsphere::Interface
mac="00:XX:XX:XX:XX:XX",
network=nil,
name="Network adapter 1",
status="untried",
connected=false,
summary="DVSwitch: 17 6e 0e 50 22 4d 5d 07-f8 71 78 86 53 9c 7b f3",
type=RbVmomi::VIM::VirtualVmxnet3,
key=4000,
virtualswitch=nil,
server_id="500e25d1-8178-d44b-0974-ba04d811330b"
>
]
>
2019-06-19T09:35:35 [W|app|e0041] Orchestration::Compute: Could not match network interface #<Nic::Managed id: nil, mac: nil, ip: "10.0.0.1", type: "Nic::Managed", name: "host.example.com", host_id: nil, subnet_id: 1, domain_id: 1, attrs: {}, created_at: nil, updated_at: nil, provider: nil, username: nil, password: nil, virtual: false, link: true, identifier: "", tag: "", attached_to: "", managed: true, mode: "balance-rr", attached_devices: "", bond_options: "", primary: true, provision: true, compute_attributes: {"type"=>"VirtualVmxnet3", "network"=>"network-5366"}, execution: true, ip6: "", subnet6_id: nil>
2019-06-19T09:35:35 [W|app|e0041] Could not find virtual machine network interface matching 10.0.0.1
2019-06-19T09:35:35 [W|app|e0041] Rolling back due to a problem:
-----------------

Reproducing environment:

Standard Switches, no Distributed Switches
ESXi servers in cluster have network each on them with same names

Version-Release number of selected component (if applicable):
Satellite 6.4

How reproducible:
Specific to VMware environment as explained above

Actual results:

Fails with error Could not find virtual machine network interface matching <IP>

Expected results:

Build system without issues


Related issues

Has duplicate Foreman - Bug #27352: VMware Image based Provisioning fails with error- : Could not find virtual machine network interface matching <IP>Duplicate

Associated revisions

Revision 97e72f86 (diff)
Added by Ondřej Ezr about 1 year ago

Fixes #27353 - use vmware network id instead of name

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6918 added

#2 Updated by Ondřej Ezr over 1 year ago

This is caused by multiple networks, which has the same name. When switching to provisioning by network id, the issue was fixed.
The PR is doing exactly that.

#3 Updated by Ondřej Ezr over 1 year ago

  • Triaged changed from No to Yes
  • Difficulty set to easy
  • Assignee changed from Chris Roberts to Ondřej Ezr

#4 Updated by The Foreman Bot about 1 year ago

  • Fixed in Releases 1.24.0 added

#5 Updated by Ondřej Ezr about 1 year ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Ondřej Ezr 11 months ago

  • Has duplicate Bug #27352: VMware Image based Provisioning fails with error- : Could not find virtual machine network interface matching <IP> added

Also available in: Atom PDF