Project

General

Profile

Bug #27362

VMware resource pools are populated only from first cluster found

Added by Ondřej Ezr 8 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1578911

Description of problem:
Customer has multiple vmware clusters under vmware datacenter and each of this clusters has it's own resource pool.
When trying to provision vm under any other than first vm_cluster, resource pools can't be selected and only initial once are displayed.

Version-Release number of selected component (if applicable):
satellite 6.3.1
esx and vcenter components will be updated later

How reproducible:
configure vcenter compute resource on satellite 6.3.1 and make sure that your vmware datacenter has multiple clusters and each has own resource pools
try to provision new vm in any other than first vm_cluster.
If you select resource pool other than generic it will fail.

Steps to Reproduce:
1.see above

Actual results:
resource pool in select field is from first cluster
provision fail if they are selected, or you have to select generic one and than manually change it.

Expected results:
resource pool should be populated each time you select different vmware cluster.

Additional info:


Related issues

Is duplicate of Foreman - Bug #27363: VMware resource pools are populated only from first cluster foundClosed

History

#1 Updated by Ondřej Ezr 4 months ago

  • Triaged changed from No to Yes
  • Status changed from New to Duplicate

Dup of #27363

#2 Updated by Ondřej Ezr 4 months ago

  • Is duplicate of Bug #27363: VMware resource pools are populated only from first cluster found added

Also available in: Atom PDF