Project

General

Profile

Bug #27369

jest uses outdated packages when linking foeman-js

Added by Amir Fefer 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
JavaScript stack
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

how to reproduce:
a. update a package that breaks a test in foreman-js
b.link foreman-js to foreman core by running

npm run foreman-js:link

c. run tests
Actual: No test failures
Expected: at least one test failure

Associated revisions

Revision 230925d2 (diff)
Added by Amir Fefer 5 months ago

Fixes #27369 - fix jest when updating a package in foremanjs

History

#1 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6925 added

#2 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 1.23.0 added

#3 Updated by Amir Fefer 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF