Project

General

Profile

Bug #27375

Some options in 'host update --help' are printed twice

Added by Martin Bacovsky 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Hosts
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

hammer host update --help                              
Usage:
    hammer host update [OPTIONS]

Options:
 --ansible-role-ids ANSIBLE_ROLE_IDS                           IDs of associated ansible roles
                                                               Comma separated list of values. Values containing comma should be quoted or escaped with backslash.
                                                               JSON is acceptable and preferred way for complex parameters
 --ansible-roles ANSIBLE_ROLE_NAMES                            Comma separated list of values. Values containing comma should be quoted or escaped with backslash.
                                                               JSON is acceptable and preferred way for complex parameters
 --architecture ARCHITECTURE_NAME                              Architecture name
 --architecture-id ARCHITECTURE_ID                              
 --ask-root-password ASK_ROOT_PW                               One of true/false, yes/no, 1/0.
 --ask-root-password ASK_ROOT_PW                               One of true/false, yes/no, 1/0.
 --autoheal AUTOHEAL                                           Sets whether the Host will autoheal subscriptions upon checkin
                                                               One of true/false, yes/no, 1/0.
 --build BUILD                                                 One of true/false, yes/no, 1/0.
 --comment COMMENT                                             Additional information about this host
 --compute-attributes COMPUTE_ATTRS                            Compute resource attributes
                                                               Comma-separated list of key=value.
                                                               JSON is acceptable and preferred way for complex parameters
 --compute-attributes COMPUTE_ATTRS                            Compute resource attributes
                                                               Comma-separated list of key=value.
                                                               JSON is acceptable and preferred way for complex parameters
 --compute-profile COMPUTE_PROFILE_NAME                        Compute profile name
 --compute-profile-id COMPUTE_PROFILE_ID                        
 --compute-resource COMPUTE_RESOURCE_NAME                      Compute resource name
 --compute-resource-id COMPUTE_RESOURCE_ID                      
 --config-group-ids CONFIG_GROUP_IDS                           IDs of associated config groups
                                                               Comma separated list of values. Values containing comma should be quoted or escaped with backslash.
                                                               JSON is acceptable and preferred way for complex parameters
 --config-groups CONFIG_GROUP_NAMES                            Comma separated list of values. Values containing comma should be quoted or escaped with backslash.
                                                               JSON is acceptable and preferred way for complex parameters
 --content-source CONTENT_SOURCE_NAME                          Content Source name
 --content-source-id CONTENT_SOURCE_ID                          
 --content-view CONTENT_VIEW_NAME                              Name to search by
 --content-view-id CONTENT_VIEW_ID                             Content view numeric identifier
 --domain DOMAIN_NAME                                          Domain name
 --domain-id DOMAIN_ID                                         Numerical ID or domain name
 --enabled ENABLED                                             Include this host within Foreman reporting
                                                               One of true/false, yes/no, 1/0.
 --environment ENVIRONMENT_NAME                                Environment name (--environment is deprecated: Use --puppet-environment instead)
 --environment-id ENVIRONMENT_ID                               (--environment-id is deprecated: Use --puppet-environment-id instead)
 --hostgroup HOSTGROUP_NAME                                    Hostgroup name
 --hostgroup-id HOSTGROUP_ID                                    
 --hostgroup-title HOSTGROUP_TITLE                             Hostgroup title
 --hypervisor-guest-uuids HYPERVISOR_GUEST_UUIDS               List of hypervisor guest uuids
                                                               Comma separated list of values. Values containing comma should be quoted or escaped with backslash.
                                                               JSON is acceptable and preferred way for complex parameters
 --id ID                                                        
 --image IMAGE_NAME                                            Name to search by
 --image-id IMAGE_ID                                            
 --installed-products-attributes INSTALLED_PRODUCTS_ATTRIBUTES List of products installed on the host
                                                               Comma separated list of values defined by a schema. See Option details section below.
                                                               JSON is acceptable and preferred way for complex parameters
 --interface INTERFACE                                         Interface parameters
                                                               Comma-separated list of key=value.
                                                               JSON is acceptable and preferred way for complex parameters
                                                               Can be specified multiple times.
 --interface INTERFACE                                         Interface parameters
                                                               Comma-separated list of key=value.
                                                               JSON is acceptable and preferred way for complex parameters
                                                               Can be specified multiple times.

The cause is duplicate inclusion of the option definitions in the Update command.

Associated revisions

Revision cc88d669 (diff)
Added by Martin Bacovsky 3 months ago

Fixes #27375 - remove duplicate options

History

#2 Updated by The Foreman Bot 3 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/433 added

#3 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases hammer-cli-foreman-0.18.0 added

#4 Updated by Martin Bacovsky 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF