Project

General

Profile

Actions

Bug #27391

closed

Discrepancy in default memory size for virtual machine while provisioning vm

Added by Marek Hulán almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - libvirt
Target version:
-

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1720643

Description of problem:
Default memory size for virtual machine is in Bytes (2147483648) while creating host
Also, the information icon for memory is unresponsive.

Version-Release number of selected component (if applicable):
Satellite version: 6.6.0 snap 6

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Hosts and click on create hosts link.
2. Configure host parameters in host tab.
3. Switch to virtual machine tab.
4. Check the default memory size.
5. Click on the information icon for Memory.
6. Provide value in single digit eg. 2 or 4 and create host.

Actual results:
- Host parameters are configured properly. No issues seen.
- Virtual machine tab shows very high value for Memory - 2147483648 (which converts to 2 GB). This value is supposedly in Bytes considering 2GB to be the default value.
- Clicking on information icon is unresponsive. No information is shown to user about the unit of value.
- Single digit value is correctly applied - eg. if 2 is provided then host is provisioned with 2 GB memory.

Expected results:
- Memory size value should be in GB by default.
- Information icon should provide the unit info for memory size.

Additional info:


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #27798: Host form doesn't update properly on hostgroup/taxonomy changeClosedOndřej EzrActions
Actions #1

Updated by Ondřej Ezr almost 5 years ago

  • Subject changed from Discrepancy in default memory size for virtual machine while provisioning vm from Satellite 6 to Discrepancy in default memory size for virtual machine while provisioning vm from Satellite 6
  • Category changed from Compute resources - VMware to Compute resources - libvirt
  • Triaged changed from No to Yes

It is caused by event 'ContentLoaded' is fired before the DOM the jquery prepared DOM is rendered into real DOM.
The bytes spinner is than loaded incorrectly and the spinner is not initialized.

Actions #2

Updated by The Foreman Bot almost 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6930 added
Actions #3

Updated by Ondřej Ezr over 4 years ago

  • Related to Bug #27764: VM tab on create host has storage section missing when provider selected through hostgroup added
Actions #4

Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/foreman/pull/7023 added
Actions #5

Updated by Ondřej Ezr over 4 years ago

  • Related to deleted (Bug #27764: VM tab on create host has storage section missing when provider selected through hostgroup)
Actions #6

Updated by Ondřej Ezr over 4 years ago

  • Related to Bug #27798: Host form doesn't update properly on hostgroup/taxonomy change added
Actions #7

Updated by The Foreman Bot over 4 years ago

  • Fixed in Releases 1.24.0 added
Actions #8

Updated by Tomer Brisker over 4 years ago

  • Fixed in Releases 1.23.0 added
  • Fixed in Releases deleted (1.24.0)
Actions #9

Updated by Ondřej Ezr over 4 years ago

  • Status changed from Ready For Testing to Closed
Actions #10

Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/foreman/pull/7026 added
Actions #11

Updated by Tomer Brisker over 4 years ago

  • Subject changed from Discrepancy in default memory size for virtual machine while provisioning vm from Satellite 6 to Discrepancy in default memory size for virtual machine while provisioning vm
Actions #12

Updated by Tomer Brisker over 4 years ago

  • Fixed in Releases 1.22.2 added
Actions

Also available in: Atom PDF