Project

General

Profile

Bug #27426

enabled repository does not show under 'Enabled Repository' view without refresh the page

Added by Walden Raines 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1716877

Description of problem:

enabled repository does not show under 'Enabled Repository' view without refresh the page

Version-Release number of selected component (if applicable):

Satellite 6.6.0 snap 5.0

How reproducible:

Steps to Reproduce:

1. Install fresh Satellite
2. upload manifest
3. Navigate to , Content > Red Hat Repositories
4. Try to enable any repo

Actual results:

You shall be able to see repo enable pop-up notification but repo will not show under 'Enabled Repository' view without page refresh

Expected results:

Repo should show under 'Enabled Repository' view without page refresh

Additional info:

screen shot attached


Related issues

Has duplicate Katello - Bug #27198: UI sends malformed API request upon enabling *first* redhat repoDuplicate

Associated revisions

Revision cb1db059 (diff)
Added by Jeremy Lenz 2 months ago

Fixes #27426: katello sends invalid page number request

When you have no Red Hat Repositories enabled and try to enable one, the
newly enabled repository would not show until after a page refresh.
This was due to an invalid page number (0) in the request

History

#1 Updated by Walden Raines 3 months ago

  • Assignee set to Walden Raines

#2 Updated by Justin Sherrill 2 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.13.0

#3 Updated by Walden Raines 2 months ago

  • Assignee changed from Walden Raines to Jeremy Lenz

#4 Updated by The Foreman Bot 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8258 added

#5 Updated by Jeremy Lenz 2 months ago

I can recreate the issue reliably, as long as the Red Hat Repository is the first one you try to enable (e.g. there are no Red Hat Repositories already enabled)

Additional symptoms:

#6 Updated by Jeremy Lenz 2 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Samir Jha 2 months ago

  • Has duplicate Bug #27198: UI sends malformed API request upon enabling *first* redhat repo added

Also available in: Atom PDF