Project

General

Profile

Bug #27500

rake db:migrate fails on missing relation when registering fields from plugins

Added by Ondřej Pražák 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Steps to reproduce:

1) have a foreman where db:create and db:migrate was already executed
2) add a plugin registering graphql fields with plugin dsl, bundle
3) run db:migrate

The cause is that `field` methods are called within the type class immediately when the class constant is used, so we need to use strings for registration and constantize later.


Related issues

Related to Foreman - Feature #27190: graphql: add plugin DSL for registering plugin fieldsClosed

Associated revisions

Revision d84dfbbd (diff)
Added by Ondřej Pražák 5 months ago

Fixes #27500 - Use strings to register graphql types

History

#1 Updated by Ondřej Pražák 6 months ago

  • Related to Feature #27190: graphql: add plugin DSL for registering plugin fields added

#2 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/6949 added

#3 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 1.24.0 added

#4 Updated by Ondřej Pražák 5 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Amit Upadhye 3 months ago

  • Category set to API

Also available in: Atom PDF