Project

General

Profile

Bug #27555

Can't add EC2 CR (ISE, Fog::AWS::Compute::Error: AuthFailure)

Added by Marek Hulán about 1 month ago. Updated 17 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Compute resources - EC2
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1723733

Description of problem:
When trying to add a Compute Resource of type EC2 (when Loading Regions), I get the following error in WebUI: "An error occurred while testing the connection: Internal Server Error". The resource is then not added.

Also, I get the traceback (attached) in logs.
The traceback suggests that there are wrong credentials but I triple-checked them and the same credentials work for me on Sat 6.5.

Version-Release number of selected component (if applicable):
Reproduced on 3 different hosts with Sat 6.6 snap 7. Couldn not reproduce on Sat 6.5.

How reproducible:
Deterministic

Steps to Reproduce:
1. Infrastructure -> Compute Resources -> Create
2. Select type AWS
3. Enter your Access Key and Secret Key
4. Click "Load Regions"

Actual results:
Error, traceback

Expected results:
Regions loaded

History

#1 Updated by Lukas Zapletal 17 days ago

  • Triaged changed from No to Yes
  • Status changed from New to Rejected
  • Subject changed from Can't add EC2 CR (ISE, Fog::AWS::Compute::Error: AuthFailure) to Can't add EC2 CR (ISE, Fog::AWS::Compute::Error: AuthFailure)

We are not able to reproduce this.

Also available in: Atom PDF