Project

General

Profile

Bug #27572

Default "Filter Errata Type" value in "Applied Errata" report leads to empty output

Added by Marek Hulán about 1 month ago. Updated 21 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Statistics
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1727928

Description of problem:
When I don't select errata type while generating the Applied Errata report, it produces empty output. Not even header is in the resulting file.

Version-Release number of selected component (if applicable):
Reproduced on Sat 6.6 snap 10.

How reproducible:
Deterministic

Steps to Reproduce:
1. Have a Satellite, a content host fully registered to it (bootstrap, katello-agent)
2. Have some erratum applicable to that content host
3. Go to the content host page -> Errata
4. Select some erratum
5. Click "Apply Selected"
6. Monitor -> Report Templates
7. Generate "Applicable Errata"
8. Default values, Submit

Actual results:
Empty file

Expected results:
File with at least a header and an entry for the applied erratum. I think not filling the field should be interpreted as "all".

Additional information:
Tested with errata applied through katello-agent because I'm blocked on testing with remote execution due to bug 1727927.


Related issues

Related to Katello - Refactor #27709: Allow load_errata_applications to accept nil/blank valueClosed

History

#1 Updated by Ondřej Ezr 26 days ago

  • Related to Refactor #27709: Allow load_errata_applications to accept nil/blank value added

#2 Updated by Ondřej Ezr 21 days ago

  • Status changed from New to Closed
  • Subject changed from Default "Filter Errata Type" value in "Applied Errata" report leads to empty output to Default "Filter Errata Type" value in "Applied Errata" report leads to empty output

Fixed by #27709.

Also available in: Atom PDF