Project

General

Profile

Feature #27647

HostCollection Errata Install WebUI errata selection and pagination issues

Added by Walden Raines about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Host Collections
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1731136

Description of problem:
Using Errata Installation for a Host Collection has multiple issues, all related to incorrect handling of errata selection .

Version-Release number of selected component (if applicable):
Sat 6.6 Snap 11

How reproducible:
always

Steps to Reproduce:
1. Create a Host Collection and assing multiple hosts with installable errata to it. I have used released RHEL 7.6 without any updates.
2. Navigate to Hosts-> Host Collectins -> <host collection created in step 1>
3. Click Errata Installation

Now you can encounter multiple issues with a common root cause (I guess):
You start with pagination of 20 items per page by default. Select a few errata (3 in my case).

- if you change the page, you can see there are still 3 of 80 errata selected. If you change the page back to the initial one, there are still 3 of 80 selected, but you can't see the checkmarks at the errata you have previously selected anymore - all checkmarks are empty.

- same thing happens if you change the pagination number e.g. from 20 to 50. Checkmarks are gone, yet the dialog still states there are 3 of 80 selected.

- only way how to clean the selection is to click on the "Refresh Table" button, close the dialog, or click the "select all" checkmark button in the column header.

- if you use the column checkmark button to select all errata, only the errata on the current page is selected. Fair enough. The problem is, if you switch the page, naturally no errata is selected on the the new page, but the column header check button is still checked. Clicking it clears out the selection you have made on the previous page, and has no effect on the current page selection. It means the user is not able to select all the errata on a multipage dialog using the column button - only by manually clicking each erratum on subsequent pages.

- this works the other way as well - if you manually select some errata on one page, then switch the page, and use the check button in the column header to select all errata on the current page, previously manually selected errata is cleared, and only the errata on the current page is selected (at least according to "x of y selected" line, as it is not possible to check the selection because of the issues described above)

- if you successfully select all the errata on all pages in the dialog, change the page again, and then manually start selecting the (now clean) checkmarks, the status line starts to overflow, showing things like 90 of 80 selected. See the attached screenshot.

- as for the functionality itself - changing the page really clears the selection, even if the status line claims there are some errata selected. The "Install Selected" button is still active and can be pressed. Doing so causes the an error message "No content has been provided". Only checkmarks that are actually present and visible are taken into account when submitting the installation job.

Actual results:
The checkmarks handling is inconsistent, and it is actually not possible to select errata from multiple pages.

Expected results:
Checkmarks are preserved despite the page and pagination size changes. The status line showing number of selected errata reflects the real state of selection. Errata on multiple pages can be selected.


Related issues

Related to Katello - Bug #29374: bulk errata install prefers errata_ids even when install_all is passedClosed

Associated revisions

Revision 3b7824c6 (diff)
Added by Justin Sherrill 8 months ago

Refs #27647 - Provide ability to install all errata

Revision 667ff57a (diff)
Added by Walden Raines 8 months ago

Fixes #27647: enable true select all on HC errata

Include true select all functionality on the host collection errata
modal.

https://projects.theforeman.org/issues/27647

History

#1 Updated by Samir Jha about 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.14.0

#2 Updated by Partha Aji 11 months ago

  • Tracker changed from Bug to Feature

This behavior is true for any bastion page. Same behavior is observed if
1) you had a 30 products
2) goto Content -> Products,
3) Select a couple of items
4) Hit >
5) Hit <

The way bastion was written the item selections were not meant to be persistent (been the case since 2013). This to me appears to be new feature as opposed to it being a bug.

#3 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8531 added

#4 Updated by The Foreman Bot 8 months ago

  • Pull request https://github.com/Katello/katello/pull/8526 added

#5 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases Katello 3.16.0 added

#6 Updated by Walden Raines 8 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Jonathon Turel 8 months ago

  • Target version changed from Katello 3.14.0 to Katello 3.15.0

#8 Updated by Justin Sherrill 6 months ago

  • Related to Bug #29374: bulk errata install prefers errata_ids even when install_all is passed added

Also available in: Atom PDF