Project

General

Profile

Bug #27648

cannot select ALL erratas to content hosts, only one PAGE of erratas AT A TIME [6.3]

Added by Walden Raines about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1631957

Description of problem:

In HOSTS -> CONTENT HOSTS, when selecting hosts and trying to apply all installable erratas (with SELECT ACTION -> Manage Errata, with selected hosts) one cannot select all erratas.
Normally there are around 300 erratas on a new installed system. One can increase the page size up to 100 elements. That makes the minimum of 3 pages possible.
The issue if that selecting the total checkbox, it selects ONLY the current page.
When one switches to the NEXT PAGE, the selected items are KEPT SELECTED (that is OK) but the total checkbox is ALREADY SELECTED, so it deselects the previous page when clicked.
IF one selects any other errata individually on the next page, it adds up to the total. Currently it is not possible to select x content hosts and apply ALL erratas to them with this issue.

Version-Release number of selected component (if applicable):
6.3.3

How reproducible:
always

Steps to Reproduce:
1. Go to HOSTS -> CONTENT HOSTS
2. Select HOSTS to apply errata (EXAMPLE: lifecycle_environment = PRE-PROD)
3. In the example i selected a test content host (the only one in PRE-PROD lifecycle_environment)
4. Click Select Action -> MANAGE ERRATA
5. Click the page total checkbox, all page erratas are selected (using 100 page results, best case [default=20]) 100/300 selected. (OK)
6. Go to the bottom of the page ... (scroll down... why?)
7. Go to next page
8. Go to the top of the page ... (scroll up ... why?)
9. One will find the page total checkbox ALREADY checked instead of not checked...
10. Clicking it will UN-select the previous errata selected from the previous pages....

Actual results:
When selecting which errata to apply to selected content hosts, one cannot select ALL erratas in ONE CLICK.
When going to the next page, the total checkbox is KEEPT SELECTED instead of NOT SELECTED, so you cannot click it again to add the page to the total.

Expected results:
Having ONE SUPER-TOTAL checkbox for ALL erratas (currently this does not exists)
Fix the PAGE TOTAL checkbox behavior when switching pages so that one can add at least the current page erratas to the total. (this is not working/bugged)

Additional info:

See attached screenshots.


Related issues

Is duplicate of Katello - Feature #26811: No Select All option in Content Host Errata pageClosed

History

#1 Updated by Samir Jha about 1 year ago

  • Related to Feature #26811: No Select All option in Content Host Errata page added

#2 Updated by Samir Jha about 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello Backlog
  • Assignee set to Walden Raines

#3 Updated by Walden Raines about 1 year ago

  • Related to deleted (Feature #26811: No Select All option in Content Host Errata page)

#4 Updated by Walden Raines about 1 year ago

  • Status changed from New to Duplicate

Duplicate of #26811

#5 Updated by Walden Raines about 1 year ago

  • Is duplicate of Feature #26811: No Select All option in Content Host Errata page added

Also available in: Atom PDF