Project

General

Profile

Bug #27657

Forman/Katello issue with Puppet6 after upgrading Foreman/katello and Puppet server

Added by Jean-Marie Magnier almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

FOREMAN SERVER
OS Version : CentOS 7.6-1810
Foreman Version : 1.22.0
Katello : 3.12.1

PUPPET SERVER
OS Version : CentOs 7.6-1810
Puppet server : 6.5.0-1.el7
Puppet agent : 6.7.2-1.el7

Error Message
Tried to load unspecified class: Time

After upgrading to new version the puppet server, I Receive error when i try to run puppet on client. It seem to be similar to :
  • "https://tickets.puppetlabs.com/browse/PUP-9506"
Opened and described in :
  • "https://projects.theforeman.org/issues/26763#change-124655".
fixed by :
  • "https://github.com/Katello/katello/pull/8147"

in katello V3.12.1

But for me the pb is issued is always present.

Normally the pb is in katello_server:<path>/info_provider.rb.
The puppet:<path>/node.rb return a bad time format.

I hava added some file for helping you.

I have found a workaroud, but I m not satisfied about. workaroud code modification :
27 content_view_info = {
28 'label' => host.content_view.try(:label),
29 'latest-version' => host.content_view.try(:latest_version),
30 'version' => content_version.try(:version),

31           'published' => content_version.try(:created_at).try(:time).to_s *+ " "*,

32 'components' => content_view_components
33 }

History

#1 Updated by Jean-Marie Magnier almost 3 years ago

Some additional information about code modification.
- File <foreman server>/<path>/info_provider.rb

#2 Updated by Samir Jha over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.14.0
  • Assignee set to Chris Roberts

#3 Updated by Wagner Sartori Junior over 2 years ago

I'm having this problem when using --no-environment on node.rb. Without it works fine.

I'm running katello-3.13.2-1.el7.noarch

I ran node.rb manually with and without --no-environment, and this is the diff:

--- env    2019-12-18 13:39:36.782264707 +0000
+++ no_env    2019-12-18 13:39:42.786281857 +0000
@@ -9,23 +9,23 @@
     label: CentOS_7_Gluster_6
     latest-version: '35.0'
     version: '35.0'
-    published: 2019-12-10 12:47:42 UTC
+    published: 2019-12-10 12:47:42.000000000 +00:00
     components:
       CentOS_7_Base:
         version: '8.0'
-        published: 2019-11-25 08:55:04 UTC
+        published: 2019-11-25 08:55:04.000000000 +00:00
       EPEL_7:
         version: '5.0'
-        published: 2019-11-20 10:42:50 UTC
+        published: 2019-11-20 10:42:50.000000000 +00:00
       Gluster_6:
         version: '4.0'
-        published: 2019-11-20 11:28:20 UTC
+        published: 2019-11-20 11:28:20.000000000 +00:00
       [REDACTED]:
         version: '15.0'
-        published: 2019-12-10 12:47:24 UTC
+        published: 2019-12-10 12:47:24.000000000 +00:00
       Clients:
         version: '9.0'
-        published: 2019-11-25 14:26:44 UTC
+        published: 2019-11-25 14:26:44.000000000 +00:00
   kickstart_repository:
   hostgroup: prd/gluster
   realm: [REDACTED]
@@ -329,9 +329,9 @@
   remote_execution_effective_user_method: sudo
   remote_execution_connect_by_ip: false
 classes: {}
-environment: production

#4 Updated by Jonathon Turel over 2 years ago

  • Triaged changed from Yes to No
  • Target version deleted (Katello 3.14.0)

#5 Updated by John Mitsch over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0
  • Category set to 89

#6 Updated by Chris Roberts about 2 years ago

  • Status changed from New to Need more information

Hi Wagner,

Can you attempt to upgrade to Katello 3.14 and let us know if the issue is still present?

#7 Updated by Chris Roberts about 2 years ago

  • Target version changed from Katello 3.16.0 to Katello Recycle Bin
  • Status changed from Need more information to Closed

I have not heard back in 16 days, if the issue is still present feel free to create a new issue.

Thanks,

- Chris

#8 Updated by Jean-Marie Magnier about 2 years ago

  • File deleted (info_provider.rb)

#9 Updated by Jean-Marie Magnier about 2 years ago

  • File deleted (puppetserver.log)

#10 Updated by Jean-Marie Magnier about 2 years ago

  • File deleted (puppetserver-access.log)

#11 Updated by Jean-Marie Magnier about 2 years ago

  • File deleted (node.rb)

#12 Updated by Jean-Marie Magnier about 2 years ago

  • File deleted (node.rb_query_result)

#13 Updated by Jean-Marie Magnier about 2 years ago

  • File deleted (puppet_client.trace)

Also available in: Atom PDF