Project

General

Profile

Bug #27684

[Kubevirt-Foreman] PVC size has no validation

Added by Shira Maximov over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1700769

Description of problem:
The size of PVC has no validation in the Create host form

production.log
```
<Kubeclient::HttpError> PersistentVolumeClaim in version "v1" cannot be handled as a PersistentVolumeClaim: v1.PersistentVolumeClaim.Spec: v1.PersistentVolumeClaimSpec.AccessModes: []v1.PersistentVolumeA
ccessMode: Resources: v1.ResourceRequirements.Requests: unmarshalerDecoder: quantities must match the regular expression '^([+-]?[0-9.]+)([eEinumkKMGTP]*[-+]?[0-9]*)$', error found in #10 byte of ...|rage":"xG"}
},"access|..., bigger context ...|s-storage","resources":{"requests":{"storage":"xG"}},"accessModes":["ReadWriteOnce"]}}|...
```

Version-Release number of selected component (if applicable):
plugin master

How reproducible:

Steps to Reproduce:
1.Go to create a host
2.Under Virtual Machine tabs, add storage with wrong values
3.

Actual results:
Does not have validation, and causes wrong exception due to size format being wrong

Expected results:
Should give proper exception if the format of the entry was wrong

Additional info:

Associated revisions

Revision 6da3128b (diff)
Added by Shira Maximov over 2 years ago

Fixes #27684 - Add validation for PVC (#117)

History

#1 Updated by Shira Maximov over 2 years ago

  • Status changed from New to Closed

#2 Updated by Shira Maximov over 2 years ago

  • Pull request https://github.com/theforeman/foreman_kubevirt/pull/117 added

#3 Updated by Shira Maximov over 2 years ago

  • Fixed in Releases foreman_kubevirt_v0.1.0 added

#4 Updated by Shira Maximov over 2 years ago

  • Fixed in Releases foreman_kubevirt_v0.1.5 added
  • Fixed in Releases deleted (foreman_kubevirt_v0.1.0)

Also available in: Atom PDF