Project

General

Profile

Actions

Bug #2769

closed

[Foreman 1.2] Unable to edit hostgroup with :unattended: false

Added by Andrei Burd over 10 years ago. Updated over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Full Trace:
undefined local variable or method `freeip_subnets_path' for #<#<Class:0x7fb412462d50>:0x7fb41256e2d0>
If you feel this is an error with Foreman itself, please open a new issue with Foreman ticketing system, You would probably need to attach the Full trace and relevant log entries.

NameError
undefined local variable or method `freeip_subnets_path' for #<#<Class:0x7fb412462d50>:0x7fb41256e2d0>
app/views/common/_domain.html.erb:4:in `_app_views_common__domain_html_erb__1959494478_70205686783800'
app/views/common/_domain.html.erb:1:in `_app_views_common__domain_html_erb__1959494478_70205686783800'
app/views/common/_domain_subnet.html.erb:7:in `_app_views_common__domain_subnet_html_erb__1600280731_70205687056040'
app/views/common/_domain_subnet.html.erb:1:in `_app_views_common__domain_subnet_html_erb__1600280731_70205687056040'
app/views/hostgroups/_form.html.erb:43:in `_app_views_hostgroups__form_html_erb__1511968880_70205687993400'
app/helpers/layout_helper.rb:211:in `form_for'
app/views/hostgroups/_form.html.erb:2:in `_app_views_hostgroups__form_html_erb__1511968880_70205687993400'
app/views/hostgroups/edit.html.erb:3:in `_app_views_hostgroups_edit_html_erb__1294902193_70205688051220'
lib/foreman/thread_session.rb:31:in `clear_thread'

Everything works ok if :unattended: true.

Ubuntu 12.04, Postgres 9.1, upgraded from foreman 1.1. Foreman runs with Apache+Passenger


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Bug #2373: 'freeip_subnets_path' error when creating a new hostgroup when unattended is disabledClosedDominic Cleal04/04/2013Actions
Actions #1

Updated by Dominic Cleal over 10 years ago

  • Status changed from New to Duplicate

Dupe of #2373.

Actions

Also available in: Atom PDF