Project

General

Profile

Actions

Bug #2782

closed

LDAP Auth Source Account Password reset

Added by keith obrien almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Authentication
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Seems to be a regression Bug "872".

It seems when making changes to an LDAP Auth Source that the fake masked password (which seems to be 'xxxxxxxxxxx') then actually becomes the password to use for the Auth Source, thus making the password invalid and 'breaking' the Auth Source.

Reproduce:
In a working LDAP config simply open "LDAP Authentication" for editing and click save.

Version affected:
1.2.0+debian0.3
1.2.0+debian2

Actions #1

Updated by Ohad Levy over 10 years ago

  • Assignee set to Joseph Magen
  • Target version set to 1.2.1

seems like a missing password field, Joseph, can you have a look?

thanks

Actions #2

Updated by Joseph Magen over 10 years ago

  • Status changed from New to Ready For Testing
Actions #3

Updated by Joseph Magen over 10 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF