Project

General

Profile

Bug #27851

Unable to sync Kubernetes repository on demand

Added by Florian Faltermeier over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,

it's not possible for me to sync Kubernetes repository on demand. Other yum repos work fine.

https://packages.cloud.google.com/yum/repos//kubernetes-el7-x86_64/

Only repodata directory is available on the link above.

Regards,
Florian

History

#1 Updated by Justin Sherrill over 2 years ago

  • Assignee set to Partha Aji
  • Category set to Repositories

This is likely a pulp bug, the repodata points to packages two levels above the repodata. lets test this and open a pulp issue if we can reproduce it.

#2 Updated by Ian Ballou over 2 years ago

I'm unable to reproduce this in nightly, syncing that repo using the On Demand policy worked fine.

#3 Updated by James Jeffers over 2 years ago

  • Target version set to Katello Backlog
  • Status changed from New to Need more information

Can this be re-tried on 3.13.x?

#4 Updated by Ian Ballou over 2 years ago

  • Assignee deleted (Partha Aji)

#5 Updated by Ian Ballou over 2 years ago

  • Status changed from Need more information to New

#6 Updated by Justin Sherrill over 2 years ago

  • Triaged changed from No to Yes
  • Target version changed from Katello Backlog to Katello 3.15.0

#7 Updated by Florian Faltermeier over 2 years ago

  • Fixed in Releases Katello 3.13.1 added

James Jeffers wrote:

Can this be re-tried on 3.13.x?

Hello James,

this issues still persists on Katello 3.13.1 / Foreman 1.23.1

Regards
Florian

#8 Updated by Justin Sherrill over 2 years ago

  • Status changed from New to Need more information

i've tested this with 3.13 (pulp-server-2.20.1-2.el7.noarch) and the repository mentioned synced fine. Do you have any sort of error (possibly from /var/log/messages) that might help debug the issue?

I also tested with pulp-server-2.21 and it worked fine there too

#9 Updated by Justin Sherrill over 2 years ago

  • Assignee set to Justin Sherrill

#10 Updated by Justin Sherrill over 2 years ago

  • Target version changed from Katello 3.15.0 to Katello Recycle Bin
  • Status changed from Need more information to Rejected

Going ahead and closing this since i cannot reproduce. Feel free to reopen or opening a support thread: https://community.theforeman.org/

if anyone is able to provide more information.

Also available in: Atom PDF