Project

General

Profile

Bug #27879

iPXE Embedded loader does not put token to the DHCP filename option

Added by Lukas Zapletal about 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
DHCP
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

I've encountered two problems with iPXE Embedded:

  • DHCP filename option does not include token at all when NEW host is created (EDIT or BUILD does work fine)
  • when BUILD is canceled/exited a token which is no longer valid is inserted

For (1) the problem is that token is generated/saved after the host record is saved. Our orchestration triggers earlier than token is generated. So for this case I am proposing to change token generation to be before_validation instead of after_validation. I hope this will not cause any issues elsewhere or I have no other ideas how to fix this.

For (2) foreman_url helper is modified only to include token when build flag is on because during orchestration host record (build flag) is correctly updated but associated token is being removed after DHCP orchestration later on (expiration). And then the build flag is compared for iPXE Embedded loader hosts and DHCP update is properly scheduled.


Related issues

Related to Foreman - Bug #27877: DHCP conflict when editing PXE loader for existing hostClosed

Associated revisions

Revision 17510989 (diff)
Added by Lukas Zapletal 7 months ago

Fixes #27879 - token is properly generated for iPXE Embedded

History

#1 Updated by Lukas Zapletal about 1 year ago

  • Related to Bug #27877: DHCP conflict when editing PXE loader for existing host added

#2 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7048 added

#3 Updated by The Foreman Bot 7 months ago

  • Fixed in Releases 2.2.0 added

#4 Updated by Lukas Zapletal 7 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7975 added

Also available in: Atom PDF