Project

General

Profile

Actions

Bug #27897

closed

Param type should not be required in host(group) api

Added by Oleh Fedorenko almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

https://github.com/theforeman/foreman/pull/6965 added parameter_type and made it to be required which lacks backward compatibility and may break custom scripts (there is a problem in hammer as well: https://projects.theforeman.org/issues/27868)


Related issues 2 (0 open2 closed)

Related to Hammer CLI - Bug #27868: No way to provide type for hosts parameters in Foreman >= 1.23ClosedOleh FedorenkoActions
Related to Foreman - Feature #27544: Hosts and Hostgroups API endpoints don't provide parameter_type and hidden_value supportClosedBaptiste AgasseActions
Actions #1

Updated by The Foreman Bot almost 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7054 added
Actions #2

Updated by Ewoud Kohl van Wijngaarden almost 5 years ago

  • Related to Bug #27868: No way to provide type for hosts parameters in Foreman >= 1.23 added
Actions #3

Updated by Ewoud Kohl van Wijngaarden almost 5 years ago

  • Related to Feature #27544: Hosts and Hostgroups API endpoints don't provide parameter_type and hidden_value support added
Actions #4

Updated by The Foreman Bot almost 5 years ago

  • Fixed in Releases 1.24.0 added
Actions #5

Updated by Oleh Fedorenko almost 5 years ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF