Project

General

Profile

Bug #27908

Set global-parameter fail with 500 Internal Server Error

Added by S├ębastien Lamy over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Fail to set a global-parameter with Hammer CLI. But no error with the Web UI.

Examples:

hammer global-parameter set --name 'lang' --value 'fr_FR.UTF-8'
hammer global-parameter set --name 'timezone' --value 'Europe/Paris'

Hammer CLI Return:

500 Internal Server Error

WebUI return:

parameters are created as expected

Thank you developpers!

-----------
Foreman version 1.23.0 under a new Centos 7.

Installer command: foreman-installer
--foreman-proxy-tftp=true
--foreman-proxy-dhcp=false
--foreman-proxy-dns=false
--enable-foreman-plugin-bootdisk


Related issues

Has duplicate Hammer CLI - Bug #28060: hammer global-parameter is brokeDuplicate
Is duplicate of Foreman - Bug #27740: Cannot set parameter for hostgroupClosed

History

#1 Updated by Oleh Fedorenko over 1 year ago

  • Has duplicate Bug #28060: hammer global-parameter is broke added

#2 Updated by Oleh Fedorenko over 1 year ago

  • Triaged changed from No to Yes
  • Status changed from New to Duplicate
  • Category set to API
  • Project changed from Hammer CLI to Foreman
  • Found in Releases 1.23.0 added
  • Found in Releases deleted (hammer-cli-0.18.0)

#3 Updated by Oleh Fedorenko over 1 year ago

  • Is duplicate of Bug #27740: Cannot set parameter for hostgroup added

#4 Updated by Matthew Smith over 1 year ago

When is this fixed scheduled for as it is not listed in the Changelogs for 3.13.2 or 3.14RC1

Also available in: Atom PDF