Project

General

Profile

Bug #27929

[Kubevirt-Foreman] The creation of a compute profile with volumes and interfaces is not working properly.

Added by Shira Maximov 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1754864

Description of problem:
This PR: https://github.com/theforeman/foreman_kubevirt/pull/118
added validation on the volumes capacity, the issue is that not all compute resource has a capacity, other use size_gb or other names,
the PR causes an issue with submitting the form of compute profile, and prevent creating a new compute profiles in all compute resources (if the kubevirt plugin in installed.

Version-Release number of selected component (if applicable):
6.6

How reproducible:
100%

Steps to Reproduce:
1. Try to create a new compute profile-> submit the form and see that nothing happens.
2.
3.

Actual results:

Expected results:
submitting the form should success

Additional info:

Associated revisions

Revision 5b158249 (diff)
Added by Shira Maximov 11 months ago

Fixes #27929 - Fix capacity validation to work only on kubevirt CR (#121)

History

#1 Updated by Shira Maximov 11 months ago

  • Pull request https://github.com/theforeman/foreman_kubevirt/pull/121 added

#2 Updated by Shira Maximov 11 months ago

  • Status changed from New to Closed

#3 Updated by Ori Rabin 11 months ago

  • Bugzilla link changed from 1754864 to 1755451

Also available in: Atom PDF