Project

General

Profile

Bug #2797

Saving provisioning template ruins the template when preview mode is selected

Added by Libor Zoubek over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Sam Kottler
Category:
Web Interface
Target version:
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Steps to reproduce:

1. edit any existing provisioning template
2. do some changes in Template editor
3. hit "Preview" to see your changes
4. hit "Save" to save your template

Actual results: template gets ruined. Diff (the preview) is saved as template new version of template instead of template body itself.

Expected results: when you hit "Save" template gets saved no matter if you are looking at "Code" or "Preview"


Related issues

Related to Foreman - Bug #2826: New config templates don't save because the set_code() method empties the divClosed2013-07-24

Associated revisions

Revision 99b2e61b (diff)
Added by Sam Kottler over 6 years ago

fixes #2797 - Submit the final code, not the diff in the config template editor

Revision ac5b46e3 (diff)
Added by Sam Kottler over 6 years ago

fixes #2797 - Submit the final code, not the diff in the config template editor
(cherry picked from commit 99b2e61bed1474451fdef1852d484f009dc4cb2f)

History

#1 Updated by Ohad Levy over 6 years ago

  • Target version set to 1.2.1

#2 Updated by Sam Kottler over 6 years ago

  • Assignee set to Sam Kottler
  • Difficulty set to medium

#3 Updated by Sam Kottler over 6 years ago

  • Status changed from New to Ready For Testing
  • Difficulty changed from medium to trivial

#4 Updated by Sam Kottler over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF