Project

General

Profile

Bug #28004

katello-certs-check should set locales for $(date) commands

Added by Andreas Bleischwitz almost 3 years ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When setting LC_TIME to anything else than EN_US or C, katello-certs-check is unable to parse the date-string.

Checking server certificate encoding: 
[OK]

date: ungültiges Datum „Okt 5 12:08:34 2019“
Checking expiration of certificate: /usr/sbin/katello-certs-check: Zeile 94: [: -gt: Einstelliger (unärer) Operator erwartet.

[OK]

Checking expiration of CA bundle: /usr/sbin/katello-certs-check: Zeile 100: [: -gt: Einstelliger (unärer) Operator erwartet.
# locale |grep LC_TIME
LC_TIME="de_DE.utf8" 
katello-certs-check-fix-LC_TIME.diff katello-certs-check-fix-LC_TIME.diff 998 Bytes Fix for missing LC_TIME environment in $(date) calls Andreas Bleischwitz, 10/05/2019 12:30 PM

Related issues

Related to Installer - Bug #33109: Date used by katello-certs-check should be formatted correctly by programClosed

History

#1 Updated by Birkir Hjartarson 7 months ago

Duplicate issue: https://projects.theforeman.org/issues/33019 (fixed in Katello 4.3.0)

#2 Updated by Ewoud Kohl van Wijngaarden 7 months ago

  • Is duplicate of Bug #33019: Introduce a valid solution to fix the error "Katello::Errors::CandlepinError: Environment with id XXXX could not be found" added

#3 Updated by Ewoud Kohl van Wijngaarden 7 months ago

  • Is duplicate of deleted (Bug #33019: Introduce a valid solution to fix the error "Katello::Errors::CandlepinError: Environment with id XXXX could not be found")

#4 Updated by Ewoud Kohl van Wijngaarden 7 months ago

  • Related to Bug #33109: Date used by katello-certs-check should be formatted correctly by program added

#5 Updated by Ewoud Kohl van Wijngaarden 7 months ago

  • Status changed from New to Duplicate

Looks like you're right there's a duplicate, but it's #33109.

Also available in: Atom PDF