Project

General

Profile

Bug #2804

Spaces in location name

Added by Finke Lamein almost 6 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Search
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When you use spaces in a location name the link on the host page to find all hosts for a location fails.

given a location "city - street"

The URL on the host page becomes:
https://foreman.beheer.lan/hosts?utf8=%E2%9C%93&search=location+%3D+city+-+street

When in fact, it should be:
https://foreman.beheer.lan/hosts?utf8=%E2%9C%93&search=location+%3D+%22Gcity+-+street%22

This problem doesn't affect the location matching in parameterized classes.


Related issues

Is duplicate of Foreman - Bug #3277: Filtering host from within the organization table fails with organization names containing blanksClosed2013-10-16

History

#1 Updated by Finke Lamein almost 6 years ago

any questions, ask me here or on #theforeman nick Quattro

#2 Updated by Dominic Cleal almost 6 years ago

  • Category set to Search

#3 Updated by Finke Lamein about 3 years ago

this has been silently fixed somewhere along the line, i can't close it. it seems

#4 Updated by Dominic Cleal about 3 years ago

  • Is duplicate of Bug #3277: Filtering host from within the organization table fails with organization names containing blanks added

#5 Updated by Dominic Cleal about 3 years ago

  • Description updated (diff)
  • Status changed from New to Duplicate

Thanks for checking, it seems to have been fixed in #3277.

Also available in: Atom PDF