Project

General

Profile

Bug #28205

React issue in Foreman for Katello: subscriptions page does not track manifest action progress

Added by Justin Sherrill 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

1. go to the subscriptions page
2. import a manifest
3. progress bar never completes

This is also a problem with repo enabling

Associated revisions

Revision 77388044 (diff)
Added by Ian Ballou 11 months ago

Fixes #28205 - manifest action progress not tracked in Katello

History

#1 Updated by Justin Sherrill 12 months ago

  • Description updated (diff)

#2 Updated by Justin Sherrill 12 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.14.0

#3 Updated by Ian Ballou 11 months ago

Noticed constant polling of the manifest task even after the manifest was uploaded. The status bar was still empty:

17:11:23 rails.1   | 2019-11-12T17:11:23 [I|app|7edcc52a] Started GET "/foreman_tasks/api/tasks?search=action~organization+%27Default+Organization%27+and+result%3Dpending+and+label%3DActions::Katello::Organization::ManifestImport+or+Actions::Katello::Organization::ManifestRefresh+or+Actions::Katello::Organization::ManifestDelete+or+Actions::Katello::UpstreamSubscriptions::BindEntitlements+or+Actions::Katello::UpstreamSubscriptions::UpdateEntitlement+or+Actions::Katello::UpstreamSubscriptions::RemoveEntitlements+or+Actions::Katello::UpstreamSubscriptions::UpdateEntitlements" for 192.168.122.1 at 2019-11-12 17:11:23 +0000
17:11:23 rails.1   | 2019-11-12T17:11:23 [I|app|7edcc52a] Processing by ForemanTasks::Api::TasksController#index as JSON
17:11:23 rails.1   | 2019-11-12T17:11:23 [I|app|7edcc52a]   Parameters: {"search"=>"action~organization 'Default Organization' and result=pending and label=Actions::Katello::Organization::ManifestImport or Actions::Katello::Organization::ManifestRefresh or Actions::Katello::Organization::ManifestDelete or Actions::Katello::UpstreamSubscriptions::BindEntitlements or Actions::Katello::UpstreamSubscriptions::UpdateEntitlement or Actions::Katello::UpstreamSubscriptions::RemoveEntitlements or Actions::Katello::UpstreamSubscriptions::UpdateEntitlements"}
17:11:23 rails.1   | 2019-11-12T17:11:23 [D|app|7edcc52a] Body: {"total":19,"subtotal":0,"page":1,"per_page":20,"sort":{"by":"started_at","order":"DESC"},"results":[]}
17:11:23 rails.1   | 2019-11-12T17:11:23 [I|app|7edcc52a] Completed 200 OK in 21ms (Views: 0.3ms | ActiveRecord: 4.8ms)

#4 Updated by Brad Buckingham 11 months ago

  • Bugzilla link set to 1771092

#5 Updated by Ian Ballou 11 months ago

Issue appears to occur because

action
is undefined in
katello/webpack/scenes/Tasks/TaskActions.js:pollTaskUntilDone

#6 Updated by Ian Ballou 11 months ago

This is looking like it was caused by a change in the Foreman React code since the bug exists with Foreman 1.24 + Katello 3.13 but not with Foreman 1.23 + Katello 3.13. This community post explains in more detail: https://community.theforeman.org/t/change-in-foreman-react-code-affecting-katello-manifest-refresh-ui/16184

#7 Updated by Ian Ballou 11 months ago

  • Target version deleted (Katello 3.14.0)
  • Category changed from Subscriptions to Web Interface
  • Subject changed from subscriptions page does not track manifest action progress to React issue in Foreman for Katello: subscriptions page does not track manifest action progress
  • Project changed from Katello to Foreman

#8 Updated by Ian Ballou 11 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7179 added

#9 Updated by Jonathon Turel 11 months ago

  • Found in Releases 1.24.0 added

This should go into 1.24

#10 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases 2.0.0 added

#11 Updated by Anonymous 11 months ago

  • Status changed from New to Closed

#12 Updated by Brad Buckingham 11 months ago

  • Target version set to 1.24.0

#13 Updated by The Foreman Bot 11 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7154 added

#14 Updated by Tomer Brisker 11 months ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/7154)

#15 Updated by Tomer Brisker 11 months ago

  • Fixed in Releases 1.24.0 added
  • Fixed in Releases deleted (2.0.0)

Also available in: Atom PDF