Project

General

Profile

Bug #28210

Can edit template inputs of locked template through CLI and API

Added by Ondřej Pražák about 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Templates
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
When a template is locked, its inputs can't be edited in WebUI but they can be edited through CLI and API.

Steps to Reproduce:
0. Have some locked template
1. $ hammer template-input create --template-id <id> --input-type user --name <newname>
Template input created

Actual results:
Template input added to the template

Expected results:
I shouldn't be able to edit anything in the template

Additional info:
This is probably because template-input is handled as a different entity than the template itself


Related issues

Related to Foreman - Bug #30843: seeding fails with 'This template is locked. Please clone it to a new template to customize.'Closed

Associated revisions

Revision f7039246 (diff)
Added by Anand Agrawal 4 months ago

Fixes #28210 - API to fix Locked template input

History

#1 Updated by Ondřej Pražák about 1 year ago

  • Priority changed from High to Normal
  • Category changed from Statistics to Templates
  • Subject changed from Can edit template inputs of locked template through CLI and API to Can edit template inputs of locked template through CLI and API

#2 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7977 added

#3 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 2.3.0 added

#4 Updated by Anand Agrawal 4 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Justin Sherrill 4 months ago

  • Related to Bug #30843: seeding fails with 'This template is locked. Please clone it to a new template to customize.' added

Also available in: Atom PDF