Project

General

Profile

Bug #28238

Web ui spinner from red hat repositories page keeps loading on enabling/disabling repository

Added by Walden Raines 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1770393

Description of problem:
Web ui spinner from red hat repositories page keeps loading on enabling/disabling repository and no notification on repository enabled.
See attachment.

After refreshing the page, it shows repository enabled/disabled.

Version-Release number of selected component (if applicable):
Satellite 6.7 snap 1

How reproducible:
always

Steps to Reproduce:
1. Navigate to Red Hat repository page
2. Try to enable any repo

Actual results:
Web ui spinner from red hat repositories page keeps loading.

Expected results:
Web ui spinner should stop and notification of repo enabled.disabled should show.

Additional info:

Associated revisions

Revision e9c19dbd (diff)
Added by Walden Raines 10 months ago

Fixes #28238: pass result of await into reload.

Pass the result of async-await into the reload
handler so that it works correctly.

https://projects.theforeman.org/issues/28238

History

#1 Updated by Jonathon Turel 10 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.0

#3 Updated by The Foreman Bot 10 months ago

  • Assignee set to Walden Raines
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8434 added

#4 Updated by The Foreman Bot 10 months ago

  • Fixed in Releases Katello 3.15.0 added

#5 Updated by Walden Raines 10 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Jonathon Turel 10 months ago

  • Target version changed from Katello 3.15.0 to Katello 3.14.0

Also available in: Atom PDF