Project

General

Profile

Bug #28263

hammer --csv content-view version export-legacy stopped working after Upgrade

Added by Harald Kawalar over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

After I upgraded to Foreman 1.23.1-1, Katello 3.13.2-1 and hammer_cli 0.18.1-1 the command "hammer --csv content-view version export-legacy" stopped working.

hammer --csv content-view version export-legacy --organization-label LABEL --content-view-id ID --id ID
Could not export the content view:
wrong number of arguments (given 2, expected 3..4)

I tried many combinations but I stuck with this error.

Installed Versions:

foreman-1.23.1-1.el7.noarch
katello-3.13.2-1.el7.noarch
tfm-rubygem-hammer_cli-0.18.1-1.el7.noarch

production.log production.log 154 KB Harald Kawalar, 11/27/2019 10:27 AM
0001-customer-patch.patch 0001-customer-patch.patch 1019 Bytes Chris Roberts, 12/09/2019 05:43 PM

History

#1 Updated by Oleh Fedorenko over 2 years ago

  • Category set to Hammer
  • Project changed from Hammer CLI to Katello

#2 Updated by Chris Roberts over 2 years ago

  • Target version set to Katello 3.15.0

#3 Updated by Chris Roberts over 2 years ago

  • Status changed from New to Need more information

Hi Harald,

What is the reason you are using the export-legacy compared to the new export? Is there something that is missing out of the old one that is not present in the new export?

We will start to look into this in the interim.

#4 Updated by Harald Kawalar over 2 years ago

Chris Roberts wrote:

What is the reason you are using the export-legacy compared to the new export? Is there something that is missing out of the old one that is not present in the new export?

Hello Chris,

for now, I used the export-legacy command to export a CV to pub/export/CV on a Foreman with internet connection. This CV contains all Red Hat Products I use.
Than there is a second Foreman with no internet connection. On this Foreman, I use the pub/export/CV directory from the other Foreman as CDN and I have several Red Hat Repositories that use the pub/export/CV as Upstream URL.

I´m not sure if the new export command can provide me the same features?

Chris Roberts wrote:

We will start to look into this in the interim.

Many thanks for this!

#5 Updated by Chris Roberts over 2 years ago

  • Assignee set to Chris Roberts
  • Status changed from Need more information to Assigned

#6 Updated by Chris Roberts over 2 years ago

  • Status changed from Assigned to Need more information

Hi Harald,

I tested this today by installing Katello 3.12 which has Foreman 1.22 included. I synced 2 yum repos, created a content view, published it and was able to export without any issues.

I then upgraded to Katello 3.13.2 and Foreman 1.23.1 and tried again but could not reproduce the issue:

[root@export ~]# hammer --csv content-view version export-legacy --organization-label Default_Organization --content-view-id 2
[.................................................................................................................................................................................................................................] [100%]

[root@export ~]# rpm -qa | grep katello
katello-3.13.2-1.el7.noarch

Since I could not replicate it here, I would like to see some more information from your system.

Can I have you run the hammer command but put a `-d` in front of it like so:

hammer -d --csv content-view version export-legacy --organization-label LABEL --content-view-id ID --id ID

It should generate a Ruby traceback, if you can post that as an update I can look in the code where the issue is happening.

- Chris

#7 Updated by Harald Kawalar over 2 years ago

Chris Roberts wrote:

Can I have you run the hammer command but put a `-d` in front of it like so:

- Chris

[ INFO 2019-11-26T09:55:44 HammerCLIKatello::ContentViewVersion::LegacyExportCommand] Called with options: {"option_id"=>9168, "option_content_view_id"=>31, "option_organization_label"=>"BS"}
[ INFO 2019-11-26T09:55:44 API] Server: https://XXX.XXX.XXX
[ INFO 2019-11-26T09:55:44 API] POST /katello/api/content_view_versions/9168/export
[DEBUG 2019-11-26T09:55:44 API] Params: {}
[DEBUG 2019-11-26T09:55:44 API] Headers: {}
[DEBUG 2019-11-26T09:55:44 API] Using authenticator: HammerCLIForeman::Api::InteractiveBasicAuth
[ERROR 2019-11-26T09:55:45 API] 500 Internal Server Error
[DEBUG 2019-11-26T09:55:45 API] {
    "displayMessage" => "wrong number of arguments (given 2, expected 3..4)",
            "errors" => [
        [0] "wrong number of arguments (given 2, expected 3..4)" 
    ]
}
[DEBUG 2019-11-26T09:55:45 Exception] Using exception handler HammerCLIKatello::ExceptionHandler#handle_internal_error
[ERROR 2019-11-26T09:55:45 Exception] wrong number of arguments (given 2, expected 3..4)
Could not export the content view:
  wrong number of arguments (given 2, expected 3..4)
[ERROR 2019-11-26T09:55:45 Exception]

RestClient::InternalServerError (500 Internal Server Error):
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/abstract_response.rb:223:in `exception_with_response'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/abstract_response.rb:103:in `return!'
    /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.2.3/lib/apipie_bindings/api.rb:353:in `block in rest_client_call_block'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/request.rb:807:in `process_result'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/request.rb:725:in `block in transmit'
    /opt/rh/rh-ruby25/root/usr/share/ruby/net/http.rb:910:in `start'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/request.rb:715:in `transmit'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/request.rb:145:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/request.rb:52:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/rest-client-2.0.2/lib/restclient/resource.rb:67:in `post'
    /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.2.3/lib/apipie_bindings/api.rb:327:in `call_client'
    /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.2.3/lib/apipie_bindings/api.rb:240:in `http_call'
    /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.2.3/lib/apipie_bindings/api.rb:190:in `call_action'
    /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.2.3/lib/apipie_bindings/api.rb:185:in `call'
    /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-bindings-0.2.3/lib/apipie_bindings/resource.rb:21:in `call'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.18.1/lib/hammer_cli/apipie/command.rb:53:in `send_request'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman-0.18.1/lib/hammer_cli_foreman/commands.rb:188:in `send_request'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli_foreman_tasks-0.0.13/lib/hammer_cli_foreman_tasks/async_command.rb:14:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.18.1/lib/hammer_cli/abstract.rb:76:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.18.1/lib/hammer_cli/abstract.rb:76:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.18.1/lib/hammer_cli/abstract.rb:76:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.18.1/lib/hammer_cli/abstract.rb:76:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:132:in `run'
    /opt/theforeman/tfm/root/usr/share/gems/gems/hammer_cli-0.18.1/bin/hammer:147:in `<top (required)>'
    /bin/hammer:23:in `load'
    /bin/hammer:23:in `<main>'

#8 Updated by Chris Roberts over 2 years ago

Hi Harald,

That is good that tells me there is not an issue with hammer, I was worried since we did clean up the export/import functions a bit for 3.13

Can I have you upload the /var/log/foreman/production.log to the redmine please so I can see the Katello traceback?

#9 Updated by Harald Kawalar over 2 years ago

Chris Roberts wrote:

Hi Harald,

That is good that tells me there is not an issue with hammer, I was worried since we did clean up the export/import functions a bit for 3.13

Can I have you upload the /var/log/foreman/production.log to the redmine please so I can see the Katello traceback?

Hi Chris,

I attached the production.log (only the part, when the error occurs).

I highly appreciate your help with this, thanks!

#10 Updated by Chris Roberts over 2 years ago

Hi Harald,

Sorry for the delay the US was out on Thanksgiving holiday, I am back now.

Would you be willing to test/apply a patch for me where I can have it drop the variables in line 5 here to the production.log:

https://github.com/Katello/katello/blob/KATELLO-3.13/app/lib/actions/pulp/repository/copy_all_units.rb#L5

It looks like a new variable was added called smart proxy compared to the 3.12 branch:

https://github.com/Katello/katello/blob/KATELLO-3.12/app/lib/actions/pulp/repository/copy_all_units.rb#L5

If you are willing I will create the patch and apply it to the issue for you with steps how to apply it.

Do you have any capsules too or just the Katello server?

#11 Updated by Harald Kawalar over 2 years ago

Chris Roberts wrote:

If you are willing I will create the patch and apply it to the issue for you with steps how to apply it.

This is okay for me.

Chris Roberts wrote:

Do you have any capsules too or just the Katello server?

I have just the Katello server.

#12 Updated by Chris Roberts over 2 years ago

Hi Harald,

Can I have you download this patch to the Katello server into the following directory for me:

/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.13.3

then run:

  1. patch -p1 < 0001-customer-patch.patch
  1. systemctl restart httpd

After a few moment try the export again for me and let me know if it works?

Thanks!

#13 Updated by Harald Kawalar over 2 years ago

Chris Roberts wrote:

After a few moment try the export again for me and let me know if it works?

Hi Chris,

after applying the patch, the export command is running without any error... but the export is finished after a few seconds and I have only some repodata in /var/www/html/pub/export/.

content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/99d597a4ee4c09602265ee3fe7316836599c7076f955923bec01982cf0aff2b4-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/34249806ea9ff4a3994443301630f64e92a6d7d3219d06e767fed3482a092938-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/3d85a3787a4b2008f65c756c15f7a137f4b53f649d9b17eef430c88c9438831f-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/ff141caa155bef1a44f9469dfb4d607123e223158449fb686717ff0f9601732e-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/os/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/2/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/ansible/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/f59d779e83e1d4b8c99fe5a1e69309cd8c3f0d4c0ff25dc9207345db243c0dd8-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/1f8e9eba84aab4e2c807109e1d78778d47841ad0f27fa4276f28d01cacb164b2-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/a4541d3b832febee8b4fb78a2937c56d3f8449d25ef0b0acd368832f6234ab1c-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/d1ac5fa91ee90db5d542d36762c31a6b66b2a78366c891e32bba58c03d835c31-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/os/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/optional/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/os/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/os/repodata/f59d779e83e1d4b8c99fe5a1e69309cd8c3f0d4c0ff25dc9207345db243c0dd8-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/os/repodata/1f8e9eba84aab4e2c807109e1d78778d47841ad0f27fa4276f28d01cacb164b2-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/os/repodata/a4541d3b832febee8b4fb78a2937c56d3f8449d25ef0b0acd368832f6234ab1c-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/os/repodata/d1ac5fa91ee90db5d542d36762c31a6b66b2a78366c891e32bba58c03d835c31-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/os/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/dotnet/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/os/repodata/f59d779e83e1d4b8c99fe5a1e69309cd8c3f0d4c0ff25dc9207345db243c0dd8-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/os/repodata/1f8e9eba84aab4e2c807109e1d78778d47841ad0f27fa4276f28d01cacb164b2-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/os/repodata/a4541d3b832febee8b4fb78a2937c56d3f8449d25ef0b0acd368832f6234ab1c-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/os/repodata/d1ac5fa91ee90db5d542d36762c31a6b66b2a78366c891e32bba58c03d835c31-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/os/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/8dbd4657831f2b08f160f6e595df0296bcbdc3e48fe18a289d6665d7364d0809-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/cdd6df83651a38eb3fb235c0769118905c8c7815ea51342af40c5782da6fa851-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/b603a011ae8a042463854bfef8e41a93ff9e5a064e8cf3e3b9b23b1879e49070-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/255919ef22a2a842074bc0ca91587188c4c71b7c07aaa5fceb531294b25f323c-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/rhscl/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/os/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/os/repodata/8dbd4657831f2b08f160f6e595df0296bcbdc3e48fe18a289d6665d7364d0809-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/os/repodata/cdd6df83651a38eb3fb235c0769118905c8c7815ea51342af40c5782da6fa851-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/os/repodata/b603a011ae8a042463854bfef8e41a93ff9e5a064e8cf3e3b9b23b1879e49070-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/os/repodata/255919ef22a2a842074bc0ca91587188c4c71b7c07aaa5fceb531294b25f323c-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/os/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/x86_64/extras/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7Server/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/kickstart/repodata/repomd.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/kickstart/repodata/f59d779e83e1d4b8c99fe5a1e69309cd8c3f0d4c0ff25dc9207345db243c0dd8-filelists.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/kickstart/repodata/1f8e9eba84aab4e2c807109e1d78778d47841ad0f27fa4276f28d01cacb164b2-other.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/kickstart/repodata/a4541d3b832febee8b4fb78a2937c56d3f8449d25ef0b0acd368832f6234ab1c-primary.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/kickstart/repodata/d1ac5fa91ee90db5d542d36762c31a6b66b2a78366c891e32bba58c03d835c31-updateinfo.xml.gz
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/kickstart/repodata/a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/x86_64/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/7/7.6/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/server/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/rhel/listing
content_views/RHEL_7_Export_Composite/296.0/content/dist/listing
content_views/RHEL_7_Export_Composite/296.0/content/listing
content_views/RHEL_7_Export_Composite/296.0/listing
content_views/RHEL_7_Export_Composite/listing
content_views/listing
listing

I would expect all the data from the content view to sync the repos on my second Foreman with no internet connection.

#14 Updated by James Jeffers over 2 years ago

  • Triaged changed from No to Yes

#15 Updated by Chris Roberts over 2 years ago

Hi Harald,

That is def not the behavior we wanted.

I will keep looking, sorry for the delays

#16 Updated by Jonathon Turel over 2 years ago

  • Triaged changed from Yes to No

#17 Updated by Jonathon Turel over 2 years ago

  • Target version deleted (Katello 3.15.0)

#18 Updated by Jonathon Turel about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#19 Updated by Jonathon Turel about 2 years ago

  • Status changed from Need more information to New

#20 Updated by Jonathon Turel about 2 years ago

  • Target version changed from Katello 3.16.0 to 1223

#21 Updated by Jonathon Turel about 2 years ago

  • Target version changed from 1223 to Katello 4.0.0

#22 Updated by Chris Roberts almost 2 years ago

  • Status changed from New to Closed

Hi Harald,

Coming back to this I retested everything again and still not able to reproduce the issue.

Are you able to upgrade to the latest 3.15, I think that should solve the issue. Here are the results of my testing:

312 - 313 - able to export both custom/rh repos/content views

313 - 314 - able to export both custom/rh repos/content views

314 - 315 - able to export both custom/rh repos/content views

315 - 316 - able to export both custom/rh repos/content views

Output of my katello-export directory

[root@prtest ~]# ll /var/lib/pulp/katello-export/ -R
/var/lib/pulp/katello-export/:
total 4
drwxr-xr-x. 3 foreman foreman 4096 Jun 29 19:19 Default_Organization-customview-v1.0

/var/lib/pulp/katello-export/Default_Organization-customview-v1.0:
total 8
drwxr-xr-x. 3 foreman foreman 4096 Jun 29 19:19 Default_Organization
rw-r--r-. 1 foreman foreman 20 Jun 29 19:19 listing

/var/lib/pulp/katello-export/Default_Organization-customview-v1.0/Default_Organization:
total 8
drwxr-xr-x. 3 foreman foreman 4096 Jun 29 19:19 content_views
rw-r--r-. 1 foreman foreman 13 Jun 29 19:19 listing

rw-r--r-. 1 foreman foreman 9284 Jun 29 19:19 variciform-6.2.9-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 7152 Jun 29 19:19 vastier-1.4.9-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 59084 Jun 29 19:19 veadar-2.1.4-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 97076 Jun 29 19:19 Venditti-3.8.0-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 67476 Jun 29 19:19 verifications-10.4.1-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 100148 Jun 29 19:19 vibrissa-7.7.0-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 41492 Jun 29 19:19 villainist-9.7.1-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 96004 Jun 29 19:19 viscus-1.10.1-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 26960 Jun 29 19:19 vociferator-4.7.3-1.elfake.noarch.rpm
rw-r--r-. 1 foreman foreman 31100 Jun 29 19:19 volvullus-6.1.3-1.elfake.noarch.rpm

/var/lib/pulp/katello-export/Default_Organization-customview-v1.0/Default_Organization/content_views/customview/1.0/custom/custom/zoo/repodata:
total 24
rw-r--r-. 1 foreman foreman 2004 Jun 29 19:19 04b192e874c43ce8310711dfa6d438df43fb36cda68c45e555d355c3736829ef-comps.xml
rw-r--r-. 1 foreman foreman 1988 Jun 29 19:19 38dadc58dcf1f698b4d62084e6829f9804075e810a5dd5746488422ad57aa169-filelists.xml.gz
rw-r--r-. 1 foreman foreman 3777 Jun 29 19:19 5992d37440a895b6ed19b826a3987d6efe2eede02e58d84efbbe15f40bf44795-primary.xml.gz
rw-r--r-. 1 foreman foreman 636 Jun 29 19:19 b12ddb7d0ad80e3744022d12377835c8c123f29f6c6ed200f6832ec7e94b04d7-updateinfo.xml.gz
rw-r--r-. 1 foreman foreman 1834 Jun 29 19:19 db8b351268a79eec3fba9aa27b6990ac1704d122dc29af45f2b42c81b5b27144-other.xml.gz
rw-r--r-. 1 foreman foreman 2153 Jun 29 19:19 repomd.xml

I tried a fresh 3.15/3.16 and no issues as well as reinstalling 3.12 and upgrading it all the way.

I am going to close this issue out since it seems environmental. Feel free to open a new issue if you encounter something else.

#23 Updated by Chris Roberts almost 2 years ago

  • Target version changed from Katello 4.0.0 to Katello 3.17.0

#24 Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 3.17.0 to Katello Backlog

#25 Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello Backlog to Katello Recycle Bin

Also available in: Atom PDF