Project

General

Profile

Bug #28274

main menu navigation to all entities doesn't work from the same entity page

Added by Walden Raines 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
JavaScript stack
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1772079

Description of problem:
This doesn't work on foreman pages only (katello works fine).

When I'm at entity (e.g. subnet) details page (or edit page) and I want to navigate to All entities (subnet) by using the main menu, it doesn't work (does nothing).

This behavior change heavily influences our automation

Version-Release number of selected component (if applicable):
6.7.0-1

Steps to Reproduce:
1. navigate to any foreman entity page
2. create the entity
3. navigate to the entity "edit" page
4. use main menu to go to the same page as in step #1

Actual results:
no action is trigerred. Foreman probably treats the current page as the destination.

Expected results:
Entity overview page should be loaded

Additional info:

this is a regression from 6.6.0

Associated revisions

Revision 0601b8df (diff)
Added by Ron Lavi 2 months ago

Fixes #28274 - refactor fallback route

History

#1 Updated by Walden Raines 2 months ago

  • Category changed from Web Interface to JavaScript stack

#2 Updated by The Foreman Bot 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7180 added

#3 Updated by Walden Raines 2 months ago

  • Assignee set to Ron Lavi

#4 Updated by The Foreman Bot 2 months ago

  • Fixed in Releases 2.0.0 added

#5 Updated by Ron Lavi 2 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Tomer Brisker 2 months ago

  • Fixed in Releases 1.24.0 added
  • Fixed in Releases deleted (2.0.0)

#7 Updated by The Foreman Bot 2 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7197 added

Also available in: Atom PDF