Project

General

Profile

Refactor #28362

Fix API Middleware failure payload

Added by Redmine Asana Bot 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
JavaScript stack
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Associated revisions

Revision 7acac44c (diff)
Added by Ron Lavi 11 months ago

Fixes #28362 - fix API middleware failure payload

History

#1 Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7211 added

#2 Updated by Tomer Brisker 11 months ago

  • Assignee set to Ron Lavi
  • Category set to JavaScript stack

What failure? when?
Issues with no info aren't very useful when they just appear here from a bot so there is no one to ask for further information.
Noone outside of the asana users know if someone is already working on an issue or try to fix them before they are copied from asana, and the reviewer has no background to what the PR is trying to fix.

#3 Updated by Ron Lavi 11 months ago

From: `payload: { error, payload }`
To: `payload: { ...payload, error }`

the `payload` data will be accessed in the `reducer` as `payload` instead of `payload.payload`

#4 Updated by Ron Lavi 11 months ago

Sorry about that, we started to use the bot and I forgot to add some description before it will generate it automatically.
Update the info above,
basically the change is in the payload object which is being accessed in the reducer

#5 Updated by Tomer Brisker 11 months ago

The comment you added describes the change you did in the pr, not why it is needed, what is the bug it is trying to fix or how it can be reproduced and tested.

#6 Updated by Ron Lavi 11 months ago

  • Tracker changed from Bug to Refactor

thanks, actually it is more of a refactoring, not a bug
so it will look cleaner to access the payload of an API call failure:

From: `payload: { error, payload }`
To: `payload: { ...payload, error }`

the `payload` data will be accessed in the `reducer` as `payload` instead of `payload.payload`

#7 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases 2.0.0 added

#8 Updated by Ron Lavi 11 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF