Project

General

Profile

Bug #28383

Editing a host group result in blank page

Added by Amir Fefer 4 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

How to reproduce:
1. Configure > Host Groups > edit one
2. a blank page will appear with the following error:

activation_key_edit-1c6afff60f50622e92fb5fbeb14c1a46c9364c43041f84e134f6b1fcec5c3ed0.js:141 Uncaught TypeError: $(...).autocomplete is not a function
    at HTMLDocument.<anonymous> (activation_key_edit-1c6afff60f50622e92fb5fbeb14c1a46c9364c43041f84e134f6b1fcec5c3ed0.js:141)
    at HTMLDocument.dispatch (jquery.js:4737)
    at HTMLDocument.elemData.handle (jquery.js:4549)
    at Object.trigger (jquery.js:7807)
    at HTMLDocument.<anonymous> (jquery.js:7875)
    at Function.each (jquery.js:365)
    at jQuery.fn.init.each (jquery.js:137)
    at jQuery.fn.init.trigger (jquery.js:7874)
    at application-f7c342f65592b753016c958c3e8b668fe8253ec7d42f503ae95268704b92fe4a.js:14782
    at HTMLDocument.<anonymous> (application-f7c342f65592b753016c958c3e8b668fe8253ec7d42f503ae95268704b92fe4a.js:30)

and it is triggered because autocomplete is not a function

$("#kt_activation_keys").autocomplete() // not a function

This happens due to a regression from #25205 - replace form autocomplete in filters
jquery.ui.autocomplete is removed while katello still uses it


Related issues

Related to Foreman - Refactor #25205: Replace AutoComplete in filters forms by React SearchBarClosed

Associated revisions

Revision 67e904fa (diff)
Added by Jonathon Turel about 2 months ago

Fixes #28383 - Reinstate Activation Key autocomplete (#8541)

  • Fixes #28383 - Reinstate Activation Key autocomplete

History

#1 Updated by Amir Fefer 4 months ago

  • Related to Refactor #25205: Replace AutoComplete in filters forms by React SearchBar added

#2 Updated by Tomer Brisker 3 months ago

  • Category changed from Web Interface to Hosts
  • Project changed from Foreman to Katello

#3 Updated by Samir Jha 2 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.0

#4 Updated by Jonathon Turel 2 months ago

  • Assignee changed from Amir Fefer to Jonathon Turel
  • Status changed from New to Assigned

#5 Updated by The Foreman Bot 2 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8541 added

#6 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases Katello 3.16.0 added

#7 Updated by Jonathon Turel about 2 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF