Project

General

Profile

Bug #28627

Object references instead of values in generated reports

Added by Ondřej Pražák 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
The HTML output format is returning the object itself not the value of the object for Host Collections and Products in Entitlement report.
Subscriptions column in Registered hosts report is also affected.

Steps to Reproduce:
1. Go to monitor -> Report Templates -> Entitlements -> Generate
2. Select the Output format of HTML
3. Click submit and download the report

Actual results:
Host Collections:
#<Katello::HostCollection::ActiveRecord_Associations_CollectionProxy:0x0000000021043cd0>

Expected results: The value of the object.

Additional info: This occurs through the UI, CLI, and API.


Related issues

Related to Katello - Bug #29271: Object references instead of values in generated reportsClosed

Associated revisions

Revision aa439a68 (diff)
Added by Dominik Matoulek 5 months ago

Fixes #28627 - update entitlements report, registered hosts report and Invertory template due to added macro

History

#1 Updated by Ondřej Pražák 7 months ago

  • Category changed from Statistics to Templates
  • Subject changed from Object references instead of values in generated reports to Object references instead of values in generated reports

#2 Updated by Marek Hulán 7 months ago

we need to be extra careful with this, even if the object would render to string, it would be kept in memory during rendering, so we should make sure we only store generic types in report_row macro (e.g. calling .to_s or map { |o| o.name } is a good idea.

#3 Updated by Dominik Matoulek 6 months ago

  • Assignee set to Dominik Matoulek

#4 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/community-templates/pull/693 added

#5 Updated by Marek Hulán 5 months ago

  • Pull request https://github.com/Katello/katello/pull/8586 added

#6 Updated by Tomer Brisker 5 months ago

  • Pull request deleted (https://github.com/Katello/katello/pull/8586)

#7 Updated by Tomer Brisker 5 months ago

  • Related to Bug #29271: Object references instead of values in generated reports added

#8 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 2.1.0 added

#9 Updated by Dominik Matoulek 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF