Project

General

Profile

Bug #28629

Importing templates with 'associate: never' does not import provisioning templates

Added by Ondřej Pražák 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Importing Provisioning Template from UI with "associate: never" gives "templateKindId: can't be blank" error even though template kind is specified in metadata

template-kind-id.png View template-kind-id.png 40.6 KB Ondřej Pražák, 01/03/2020 11:09 AM
Template kind id

Associated revisions

Revision b6550cca (diff)
Added by Ondřej Pražák 8 months ago

Fixes #28629 - Always associate template kind

History

#1 Updated by Ondřej Pražák 10 months ago

  • Subject changed from [UI] Importing templates with 'associate: never' does not import provisioning templates to [UI] Importing templates with 'associate: never' does not import provisioning templates
  • File template-kind-id.png template-kind-id.png added

#2 Updated by Ondřej Pražák 9 months ago

  • Assignee set to Ondřej Pražák
  • Category set to Templates
  • Subject changed from [UI] Importing templates with 'associate: never' does not import provisioning templates to Importing templates with 'associate: never' does not import provisioning templates
  • Project changed from Templates to Foreman

The bug manifests in foreman_templates on template import, but the cause is that we skip associating template kind when 'associate' import option is 'never'. Without template kind, the provisioning template does not pass validations and it needs to be fixed in core.

#3 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7371 added

#4 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases 2.1.0 added

#5 Updated by Ondřej Pražák 8 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF