Project

General

Profile

Tracker #28633

Update GraphQL to work with Rails 6

Added by Anonymous 7 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Tests
Target version:
-
% Done:

100%

Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Some GraphQL tests fail with Rails 6 and no errors in the test logs. Probably some updates are required to the dependency gems and glue code.


Subtasks

Bug #29523: Graphql association preload doesn't work with Rails 6ClosedOndřej Ezr
Bug #29524: Update GraphQL failing tests on Rails 6ClosedOndřej Ezr

Related issues

Blocks Foreman - Tracker #24837: Rails 6.0 TrackerClosed

History

#1 Updated by Anonymous 7 months ago

#2 Updated by Ondřej Ezr 4 months ago

  • Triaged changed from No to Yes
  • % Done set to 0
  • Category changed from API to Tests
  • Tracker changed from Refactor to Tracker

#3 Updated by Ondřej Ezr 4 months ago

  • Assignee set to Ondřej Ezr

#4 Updated by Ondřej Ezr 4 months ago

  • Difficulty set to medium
  • Status changed from New to Resolved
  • Fixed in Releases 2.1.0 added

Also available in: Atom PDF