Project

General

Profile

Refactor #28638

require mocha 1.11+

Added by Anonymous 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Tests
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

#28406 pinned the mocha gem, because 1.10 was breaking tests. 1.11+ has fixed this.


Related issues

Related to Foreman - Bug #28406: SystemStackError: stack level too deep when running tests with mocha 1.10Resolved
Related to Foreman - Bug #28641: Fix mocha deprecation warnings in report_importerNew

Associated revisions

Revision 95063696 (diff)
Added by Michael Moll 7 months ago

Fixes #28638 - Require mocha 1.11+

History

#1 Updated by Anonymous 7 months ago

  • Related to Bug #28406: SystemStackError: stack level too deep when running tests with mocha 1.10 added

#2 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7326 added

#3 Updated by The Foreman Bot 7 months ago

  • Fixed in Releases 2.0.0 added

#4 Updated by Anonymous 7 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker 7 months ago

  • Related to Bug #28641: Fix mocha deprecation warnings in report_importer added

Also available in: Atom PDF