Project

General

Profile

Bug #28719

Problem adding OCS Inventory repo to Foreman Katello

Added by Alex Losa over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,
I'm trying to add an OCS Inventory repo yo my Foreman Katello, but, it doesn't work...

I can see the packet list into Foreman at Content/Packages, but, I have configurated this repo like I added my centos repos, but, the clients doesn'r see this new repo

History

#1 Updated by Alex Losa over 2 years ago

  • Priority changed from Normal to Immediate

I see that when I create the OCS repo, all is ok, but...
In "Distribution Information", tell me "No distribution available"

While in, for example a Centos 7 repo, tell me:

Distribution Information
VersiĆ³n
7
Architecture
x86_64
Family
CentOS
Variant
Bootable
true

#2 Updated by Alex Losa over 2 years ago

I'm using

Foreman 1.22
Katello 3.12

#3 Updated by Alex Losa over 2 years ago

for this problem, subscription-manager doesn't create "redhat.repo" into the client.

#4 Updated by Chris Roberts over 2 years ago

  • Priority changed from Immediate to Normal
  • Status changed from New to Need more information

Hi,

What is an OCS repo, what is the url of the repo so we can look at this further? Also has this worked on a previous version of Katello and Foreman?

#5 Updated by Alex Losa over 2 years ago

OCS Inventory repository
the URL are:

https://rpm.ocsinventory-ng.org/enterprise/6/x86_64/

and

https://rpm.ocsinventory-ng.org/enterprise/7/x86_64/

No, I have only tried in this version

#6 Updated by Ian Ballou over 2 years ago

Hi Alex,

Firstly don't worry about the distribution information, not all repositories have it.

I've synced both of the OCS repositories you've sent and added their subscription to a Katello client using Katello 3.12. When I did sudo subscription-manager repos --list, I saw the two OCS repos and could enable them. Is that what you're trying to do?

A couple things could be happening. Did you remember to add the proper subscription for your OCS repositories to the Katello client? That could cause the repositories to not show up. Also, if you're using content views or lifecycle environments you should double check that your client is configured to use the correct content view and lifecycle environment.

#7 Updated by Ian Ballou over 2 years ago

Hi Alex, do you still need help with this issue?

#8 Updated by Samir Jha over 2 years ago

  • Status changed from Need more information to Closed

Hey Alex,

Please open a new issue if you are still seeing this.

#9 Updated by James Jeffers about 2 years ago

  • Triaged changed from No to Yes

#10 Updated by James Jeffers about 2 years ago

  • Target version set to Katello 3.16.0

#11 Updated by Chris Roberts over 1 year ago

  • Triaged changed from Yes to No
  • Target version changed from Katello 3.16.0 to Katello Recycle Bin

#12 Updated by Samir Jha over 1 year ago

  • Triaged changed from No to Yes

Also available in: Atom PDF