Project

General

Profile

Bug #28733

Template editor not always allows refreshing of the preview pane

Added by Maria Agaphontzev 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Steps to Reproduce:
1. Have a few managed hosts registered to a Sat 6.7 server
2. Go to Hosts->Provisioning templates page and create a clone of a template. I have used the "Kickstart default" template.
3. Check that template can be correctly previewed. You need a managed registered host for this.
4. Make the template invalid and unrenderable. The easiest way to achieve this is to make a typo in the name of a snippet to be included in the template. I have modified the line 245 of the template, adding an extra 's' to the 'remote_execution_ssh_keys' snipet name.
5. The change correctly activates the "Change" pane of the editor.
6. Go to the "Preview" pane of the editor. Use the "Preview is Outdated..." button if necessary. You will get an error, as the template cannot be rendered at the current state. Do not close the error widget.
7. Go back to the editor pane, and fix the typo (remove the extra "s"). The "Changes" pane will be correctly disabled, as there is no change in the template now. You can close the error widget now.
8. Go to the "Preview" pane. There is still a message "Error during rendering, Return to Editor tab." in the preview area, even if the template is already fixed. There is no "Preview is Outdated..." button to refresh the preview, and you are not going to get any preview.

Preview is not available, even if the template is correct and renderable

Expected results:
If the template is correct, a preview is always available, or at least the "Preview is Outdated..." button is available to do a manual refresh.


Related issues

Is duplicate of Foreman - Bug #28731: Template editor not always allows refreshing of the preview paneClosed

Associated revisions

Revision 7e7acea8 (diff)
Added by Maria Agaphontzev 11 months ago

Fixes #28733 - Editor allow refresh preview after error

History

#1 Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7349 added

#2 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases 2.0.0 added

#3 Updated by Maria Agaphontzev 11 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Maria Agaphontzev 10 months ago

  • Is duplicate of Bug #28731: Template editor not always allows refreshing of the preview pane added

Also available in: Atom PDF