Project

General

Profile

Bug #28762

PXE templates do not render when IPv4 subnet is nil

Added by Lukas Zapletal almost 2 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

In case of IPv6 provisioning when IPv4 is unset, templates fail to render: Unable to render PXELinux template 'Kickstart default PXELinux': undefined method '#dhcp_boot_mode?' for NilClass::Jail (NilClass), Unable to render PXEGrub2 template 'Kickstart default PXEGrub2': undefined method '#dhcp_boot_mode?' for NilClass::Jail (NilClass), Unable to render PXEGrub template 'Kickstart default PXEGrub': undefined method '#dhcp_boot_mode?' for NilClass::Jail (NilClass), and Unable to render iPXE template 'Kickstart default iPXE': undefined method '#nic_delay' for NilClass::Jail (NilClass)


Related issues

Related to Foreman - Tracker #28683: IPv6 only supportNew

Related to Foreman - Feature #32321: Allow dual-stack provisioning via parameterReady For Testing
Related to Foreman - Feature #28883: Update kickstart templates for IPv6 provisioningClosed

History

#1 Updated by Lukas Zapletal almost 2 years ago

#2 Updated by Lukas Zapletal 6 months ago

  • Related to Feature #32321: Allow dual-stack provisioning via parameter added

#3 Updated by Lukas Zapletal 6 months ago

  • Triaged changed from No to Yes
  • Assignee set to Lukas Zapletal
  • Status changed from New to Resolved

Unable to reproduce anymore with Foreman 2.6 nightly, we have vastly improved this in the last year and templates (at least kickstart + pxe) now render fine on IPv6 only hosts.

#4 Updated by Lukas Zapletal 6 months ago

  • Related to Feature #28883: Update kickstart templates for IPv6 provisioning added

Also available in: Atom PDF