Project

General

Profile

Bug #28788

Backend Identifier empty on a repository page

Added by Pavel Moravec over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Opening a WebUI page with a repository, "Backend Identifier" is always empty. There should be pulp repository UUID instead - it is sometimes valuable for debugging.

Version-Release number of selected component (if applicable):
katello 3.12
(was working fine in 3.10)

How reproducible:
100%

Steps to Reproduce:
1. Enable or create some repo.
2. In WebUI, click to the repo details (via Content -> Products -> some product -> some its repo)
3. Check "Backend Identifier"

Actual results:
3. empty identifier

Expected results:
3. Should be UUID of pulp repository

Additional info:
Trivial fix:

https://github.com/Katello/katello/blob/master/app/views/katello/api/v2/repositories/base.json.rabl#L5 needs to remove the "=> :backend_identifier" bits

History

#1 Updated by Pavel Moravec over 1 year ago

  • Status changed from New to Duplicate

Pavel Moravec wrote:

Description of problem:
Opening a WebUI page with a repository, "Backend Identifier" is always empty. There should be pulp repository UUID instead - it is sometimes valuable for debugging.

Version-Release number of selected component (if applicable):
katello 3.12
(was working fine in 3.10)

How reproducible:
100%

Steps to Reproduce:
1. Enable or create some repo.
2. In WebUI, click to the repo details (via Content -> Products -> some product -> some its repo)
3. Check "Backend Identifier"

Actual results:
3. empty identifier

Expected results:
3. Should be UUID of pulp repository

Additional info:
Trivial fix:

https://github.com/Katello/katello/blob/master/app/views/katello/api/v2/repositories/base.json.rabl#L5 needs to remove the "=> :backend_identifier" bits

Duplicate of 27328

#2 Updated by Chris Roberts over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin

Also available in: Atom PDF