Project

General

Profile

Bug #28833

Deleting organization by title does not work in hammer

Added by Shira Maximov 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1763843

Description of problem:
Running hammer organization delete --title <title name> gives error.

Version-Release number of selected component (if applicable):
6.6.0_024

How reproducible:
100%

Steps to Reproduce:
1.hammer organization delete --title <title name>

Actual results:
Could not delete the organization:
Missing arguments for 'id'

Expected results:
[......................................................................................] [100%]

Additional info:
The expected result is what I really see if I ran the delete command successfully since there's no message that says "Organization Title <title name> deleted successfully."

Associated revisions

Revision 6b890a89 (diff)
Added by Shira Maximov 4 months ago

Fixes #28833 - Add title resolver to organization resource (#716)

History

#1 Updated by Shira Maximov 5 months ago

  • Assignee changed from Thomas McKay to Shira Maximov
  • Status changed from New to Assigned
  • Category changed from Organizations and Locations to Hammer

#2 Updated by The Foreman Bot 5 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/716 added

#3 Updated by Samir Jha 5 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.0

#4 Updated by Shira Maximov 4 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF