Project

General

Profile

Bug #28877

Puppet classes are missing after adding a puppet module and content view publishing

Added by Ewoud Kohl van Wijngaarden 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Description of problem:
When adding a puppet module containing some classes and publishing related content view, those classes are not created or imported to the Satellite.

How reproducible:
always

Steps to Reproduce:
1. create new product
2. create new puppet repo and synchronize it
3. create new content view and add the module
4. publish the content view - new puppet environment is created
5. check UI -> Configure -> Classes or <fqdn>/api/v2/puppetclasses or 'hammer host puppet-classes'

Actual results:
classes from the module are missing

Expected results:
classes from the module should be present

Additional notes:
When passing in --foreman-proxy-plugin-pulp-puppet-content-dir /etc/puppetlabs/code/environments it does work. The actual value is a /tmp/tmp_ which means Kafo started setting the environmentpath to the temporary path.

Associated revisions

Revision 509ca1cf (diff)
Added by Ewoud Kohl van Wijngaarden 6 months ago

Fixes #28877 - Dynamically determine Pulp Puppet dir

This change removes the default value and looks it up at runtime. The
benefit is that we can use the lookup method to get the answer for the
puppet module.

The main driver for this is that the puppet_environmentpath fact has
become unreliable with Kafo due to more isolation.

History

#1 Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/558 added

#2 Updated by The Foreman Bot 6 months ago

  • Fixed in Releases 2.0.0 added

#3 Updated by Ewoud Kohl van Wijngaarden 6 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF