Project

General

Profile

Bug #28895

Improve message on impersonation session start

Added by Ondřej Pražák 9 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Users, Roles and Permissions
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1794346

Description of problem:
During an impersonation session, in the upper right of the main menu, there is a flashing eye icon that signals to the user that they are currently engaged in an impersonation session.
This is not a problem and is in fact a good visual cue to the user.
However, I think there is an issue with the embedded assistance for this icon (UI element).

A. When a user starts an impersonation session the following notification is displayed:
"You impersonated user Richard Wright, to cancel the session, click the eye icon in the top bar."

I think the problem is 'the eye icon' -> seems like an odd choice for an icon label. It is too colloquial; if the feature name is impersonation then the icon that visually represents that feature should be called something that relates to the feature, for example 'Impersonation'.

Without a clear icon label, it is difficult to reference this UI element in the product documentation.

Is it possible to rename the icon from 'eye icon' to 'Impersonation icon' for example, or any other name that you think correctly represents the feature?

Associated revisions

Revision 11c3549f (diff)
Added by Ondřej Pražák 9 months ago

Fixes #28895 - Improve message for impersonation

History

#1 Updated by Ondřej Pražák 9 months ago

  • Assignee set to Ondřej Pražák
  • Subject changed from Improve message on impersonation session start to Improve message on impersonation session start

#2 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7400 added

#3 Updated by The Foreman Bot 9 months ago

  • Fixed in Releases 2.0.0 added

#4 Updated by Ondřej Pražák 9 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker 8 months ago

  • Category set to 218

#6 Updated by The Foreman Bot 8 months ago

  • Pull request https://github.com/theforeman/foreman/pull/7473 added

#7 Updated by Tomer Brisker 8 months ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/7473)

#8 Updated by Tomer Brisker 3 months ago

  • Category changed from 218 to Users, Roles and Permissions

Also available in: Atom PDF