Project

General

Profile

Bug #28965

Regression: Since #19389 boot image of debian is not updated and installation is broken

Added by Daniel Kraemer 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
TFTP
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Hi,

since the filenames for bootimage/initrd are containing some hash based on the media, foreman will not download new bootimages when debian is releasing a minor version like today (10.2 -> 10.3).
While the repo is updated in background, the packages, which get downloaded during preseed, doesn't match the image anymore and the installtion fails with an error.


Related issues

Related to Foreman - Feature #19389: Change TFTP filename pattern to include unique installation media IDClosed
Related to Foreman - Feature #26709: Rethink TFTP naming conventions for PXE filesNew
Related to Foreman - Bug #25733: Media provider unique ID does not work for Debian-based distrosClosed

Associated revisions

Revision c95dc347 (diff)
Added by Lukas Zapletal 10 months ago

Fixes #28965 - calculate PXE UID from OS version

History

#1 Updated by Daniel Kraemer 10 months ago

  • Related to Feature #19389: Change TFTP filename pattern to include unique installation media ID added

#2 Updated by Daniel Kraemer 10 months ago

  • Related to Feature #26709: Rethink TFTP naming conventions for PXE files added

#3 Updated by Daniel Kraemer 10 months ago

  • Status changed from New to Duplicate
  • Found in Releases 1.22.1 added
  • Found in Releases deleted (1.22.0)

#4 Updated by Daniel Kraemer 10 months ago

Actually this looks like a duplicate of https://projects.theforeman.org/issues/25733

but #25733 should already be fixed and we still suffer from this bug

#5 Updated by Tomer Brisker 10 months ago

  • Is duplicate of Bug #25733: Media provider unique ID does not work for Debian-based distros added

#6 Updated by Tomer Brisker 10 months ago

  • Is duplicate of deleted (Bug #25733: Media provider unique ID does not work for Debian-based distros)

#7 Updated by Tomer Brisker 10 months ago

  • Status changed from Duplicate to New

changing back to new since this appears to be related but not quite a duplicate

#8 Updated by Lukas Zapletal 10 months ago

Hello, I think it's still a bug. Help me to understand the problem. We currently calculate the unique ID from URL, however when Debian releases new version, the installation URL remains the same, therefore smart proxy has no reason to redownload the files (as we currently do not fetch ETAG/Last-Changed HTTP header). If we calculate the hash from the URL + minor/major version of the OS that would do it when new version is released.

#9 Updated by Lukas Zapletal 10 months ago

WORKAROUND: Delete those PXE files and smart proxy will redownload them. PR in a minute.

#10 Updated by The Foreman Bot 10 months ago

  • Assignee set to Lukas Zapletal
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7432 added

#11 Updated by Daniel Kraemer 10 months ago

Lukas Zapletal wrote:

If we calculate the hash from the URL + minor/major version of the OS that would do it when new version is released.

I guess this should fix it.

Lukas Zapletal wrote:

WORKAROUND: Delete those PXE files and smart proxy will redownload them. PR in a minute.

Yep, we've done that, worked

#12 Updated by Tomer Brisker 10 months ago

  • Related to Bug #25733: Media provider unique ID does not work for Debian-based distros added

#13 Updated by The Foreman Bot 10 months ago

  • Fixed in Releases 2.0.0 added

#14 Updated by Lukas Zapletal 10 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF