Project

General

Profile

Bug #28995

2 inputs with same name -> uninitialized constant #<Class:0x000000000b894c38>::NonUniqueInputsError

Added by Shira Maximov 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Reporting
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1756991

Description of problem:
When creating a template with 2 inputs with the same name, the error "uninitialized constant #<Class:0x000000000b894c38>::NonUniqueInputsError" appears and the operation fails. No traceback in production.log. Failure is expected but it should be handled better: the message should be more user friendly and preferably, the check should be handled before submitting the form.

Version-Release number of selected component (if applicable):
Reproduced on Sat 6.6 snap 22.

How reproducible:
Deterministic

Steps to Reproduce:
1. Monitor -> Report Templates -> Create
2. Set name
3. Go to Inputs tab
4. Add input, name it "abc"
5. Add another input, name it "abc"
6. Submit

Actual results:
Error, operation failed

Expected results:
(Form not submittable because this is checked by Javascript before submission). Better error message.

Associated revisions

Revision f75b2737 (diff)
Added by Shira Maximov 8 months ago

Fixes #28995 - change NonUniqueInputsError to Foreman::Exception

History

#1 Updated by The Foreman Bot 8 months ago

  • Assignee set to Shira Maximov
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7473 added

#2 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases 2.1.0 added

#3 Updated by Shira Maximov 8 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Tomer Brisker 8 months ago

  • Category changed from Statistics to Reporting

Also available in: Atom PDF