Project

General

Profile

Bug #28996

pulpcore 3.0.1 needs to have PULP_STATIC_ROOT set

Added by Dennis Kliban 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman modules
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

As part of an SELinux related bugfix0, the default value of PULP_STATIC_ROOT has changed from /var/lib/pulp/static/ to /var/lib/pulp/assets/.

In order to work with the pulpcore-selinux policy, pulpcore 3.0.1 installations need to:

- define PULP_STATIC_ROOT environment variable before running the 'django-admin collectstatic' command. 
- define PULP_STATIC_ROOT in the systemd unit file for pulpcore-api

This will not be necessary once pulpcore 3.2.0 is being used.

[0] https://pulp.plan.io/issues/5995


Related issues

Blocks Installer - Tracker #28736: Use Pulp 3 for File and Container content in KatelloClosed

Associated revisions

Revision 236e4d2e (diff)
Added by William Clark 8 months ago

Fixes #28996 - Set PULP_STATIC_ROOT

History

#1 Updated by Dennis Kliban 8 months ago

  • Description updated (diff)

#2 Updated by Ewoud Kohl van Wijngaarden 8 months ago

#3 Updated by Ewoud Kohl van Wijngaarden 8 months ago

#4 Updated by Ewoud Kohl van Wijngaarden 8 months ago

  • Blocks Tracker #28736: Use Pulp 3 for File and Container content in Katello added

#5 Updated by William Clark 8 months ago

  • Status changed from New to Closed

#6 Updated by Ewoud Kohl van Wijngaarden 8 months ago

  • Triaged changed from No to Yes
  • Target version set to 2.0.0
  • Assignee set to William Clark
  • Category set to Foreman modules
  • Fixed in Releases 2.1.0 added

This should be cherry picked into 2.0.0-rc3

#7 Updated by Ewoud Kohl van Wijngaarden 7 months ago

  • Fixed in Releases 2.0.0 added
  • Fixed in Releases deleted (2.1.0)

Part of theforeman-pulpcore 0.2.0 which was picked into 2.0

Also available in: Atom PDF