Project

General

Profile

Bug #29042

Applied Errata report no longer works when last reboot is included

Added by Tomer Brisker 8 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1787729

Description of problem:

When I render applied errata report, rendering fails with the message "Association named 'uptime_fact' was not found on Host::Managed; perhaps you misspelled it?"

Version-Release number of selected component (if applicable):

6.7

How reproducible:

100%

Steps to Reproduce:
1. render Applied Errata report
2. make sure to set Include Last Reboot to yes

Actual results:

Error printed

Expected results:

It should render the report with last reboot information

Additional info:

This is caused by the refactoring of reported data facet, we no longer use facts for uptime/last reboot information. The logic in "load_errata_applications" macro defined in Katello needs to be updated. See https://github.com/theforeman/foreman/pull/6843 for more details.

This would be a regression

Associated revisions

Revision b528f36e (diff)
Added by Samir Jha 8 months ago

Fixes #29042 - Applied errata report (#8584)

History

#1 Updated by Samir Jha 8 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#2 Updated by Samir Jha 8 months ago

  • Assignee set to Samir Jha

#3 Updated by Samir Jha 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8584 added

#4 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases Katello 3.16.0 added

#5 Updated by Samir Jha 8 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Ian Ballou 5 months ago

  • Category set to Errata Management

Also available in: Atom PDF