Project

General

Profile

Bug #29265

Does not load datacenter when multiple compute resources are created for same VCenter

Added by Ondřej Ezr 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1785683

Description of problem: Does not load datacenter when multiple compute resources are created for same VCenter

Version-Release number of selected component (if applicable):
foreman-1.22

How reproducible:

Steps to Reproduce:
1. Create a Compute resource for the Vcenter having multiple Datacenter
2. Click test connection and connection will be successful and will load the Datacenter.
3. Again try to create new computer resources for the same Vcenter.
4. once clicked on the Test connection, it is successful but not able to load the Datacenter list

Actual results:
Test connection successful but data centers are not listed when multiple compute resource are created for same VCenter

Expected results:
It should load dataceters list after test connection is successful.

Additional info:
This is most likely because of the cache on the datacenters list, as it gets cached under empty CR id.

Associated revisions

Revision cfb0fb2e (diff)
Added by Ondřej Ezr 5 months ago

Fixes #29265 - do not cache datacenters list

History

#1 Updated by The Foreman Bot 5 months ago

  • Assignee set to Ondřej Ezr
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7489 added

#2 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 2.1.0 added

#3 Updated by Ondřej Ezr 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF