Project

General

Profile

Bug #29278

capsule sync failed on Docker content DKR1008: Could not find registry API at https://satellite.example:5000 (Katello::Errors::PulpError)

Added by Eric Helms 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1807151

Description of problem:

capsule sync failed on Docker content DKR1008: Could not find registry API at https://satellite.example:5000 (Katello::Errors::PulpError)

Version-Release number of selected component (if applicable):

satellite-capsule-6.7.0-5.beta.el7sat.noarch
pulp-docker-plugins-3.2.5-1.el7sat.noarch
python-pulp-docker-common-3.2.5-1.el7sat.noarch

How reproducible:
New installation of 6.7 Beta

Steps to Reproduce:
1. Create a product and then create a docker repo for https://registry.access.redhat.com with Docker upstream rhel

OR

Create a product and then create a docker repo for https://registry.redhat.io with Docker upstream rhel7.7

2. Sync the repo

3. On satellite it will sync properly, it errored when capsule sync start

Content Counts
Content Type
Container Image Manifests 21
Container Image Manifest Lists 7
Container Image Tags 9

Actual results:

Feb 25 22:42:44 vm pulp: urllib3.connectionpool:INFO: [65d03eb8] Starting new HTTPS connection (1): satellite.example.com
Feb 25 22:42:44 vm pulp: nectar.downloaders.threaded:ERROR: [65d03eb8] Skipping requests to satellite.example.com:5000 due to repeated connection failures: [SSL: TLSV1_ALERT_UNKNOWN_CA] tlsv1 alert unknown ca (_ssl.c:618)
Feb 25 22:42:44 vm pulp: pulp.server.async.tasks:INFO: [65d03eb8] Task failed : [65d03eb8-5234-4bb5-b434-4c5efda9690c] : Could not find registry API at https://satellite.example.com:5000
Feb 25 22:42:44 vm pulp: celery.app.trace:INFO: [65d03eb8] Task pulp.server.managers.repo.sync.sync[65d03eb8-5234-4bb5-b434-4c5efda9690c] raised expected: PulpCodedException()
Feb 25 22:42:44 vm pulp: celery.app.trace:INFO: [2eb39e9f] Task pulp.server.async.tasks._release_resource[2eb39e9f-7bb5-4ff2-b1cc-1bd93c07f800] succeeded in 0.00347492890432s: None

Expected results:

Additional info:

I have custom SSL configured on satellite and capsules.

Associated revisions

Revision 85f85fc1 (diff)
Added by Eric Helms 9 months ago

Fixes #29278: Use default CA for crane SSL chain

History

#1 Updated by The Foreman Bot 9 months ago

  • Assignee set to Eric Helms
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman_proxy_content/pull/245 added

#2 Updated by The Foreman Bot 9 months ago

  • Fixed in Releases 2.1.0 added

#3 Updated by Eric Helms 9 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by The Foreman Bot 9 months ago

  • Pull request https://github.com/theforeman/puppet-foreman_proxy_content/pull/246 added

Also available in: Atom PDF