Project

General

Profile

Bug #29328

Error related to package while installing Katello nightly

Added by Imaan please_edit_me about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello Team,

I am trying to install katello nightly on Red Hat Enterprise Linux Server release 7.7 (Maipo) but facing some dependencies issues.

Can any one please help me with this?

I am referring this document: https://theforeman.org/plugins/katello/nightly/installation/index.html

History

#1 Updated by Imaan please_edit_me about 2 years ago

Error:

  1. yum -y install katello
    --> Processing Dependency: tfm-rubygem(hammer_cli_foreman) < 1.0.0 for package: tfm-rubygem-hammer_cli_katello-0.21-0.2.pre.master.20200204151350git3c82511.el7.noarch
    ---> Package tfm-rubygem-public_suffix.noarch 0:3.0.3-1.el7 will be installed
    ---> Package xerces-j2.noarch 0:2.11.0-17.el7_0 will be installed
    --> Processing Dependency: xml-commons-apis >= 1.4.01 for package: xerces-j2-2.11.0-17.el7_0.noarch
    --> Processing Dependency: xml-commons-resolver >= 1.2 for package: xerces-j2-2.11.0-17.el7_0.noarch
    --> Processing Dependency: osgi(javax.xml) for package: xerces-j2-2.11.0-17.el7_0.noarch
    --> Processing Dependency: osgi(org.apache.xml.resolver) for package: xerces-j2-2.11.0-17.el7_0.noarch
    --> Running transaction check
    ---> Package tfm-rubygem-hammer_cli_katello.noarch 0:0.21-0.2.pre.master.20200204151350git3c82511.el7 will be installed
    --> Processing Dependency: tfm-rubygem(hammer_cli_foreman) < 1.0.0 for package: tfm-rubygem-hammer_cli_katello-0.21-0.2.pre.master.20200204151350git3c82511.el7.noarch
    ---> Package xml-commons-apis.noarch 0:1.4.01-16.el7 will be installed
    ---> Package xml-commons-resolver.noarch 0:1.2-15.el7 will be installed
    --> Finished Dependency Resolution
    Error: Package: tfm-rubygem-hammer_cli_katello-0.21-0.2.pre.master.20200204151350git3c82511.el7.noarch (katello)
    Requires: tfm-rubygem(hammer_cli_foreman) < 1.0.0
    Installing: tfm-rubygem-hammer_cli_foreman-2.1.0-0.1.pre.develop.20200311142946git1c5c94e.el7.noarch (foreman)
    tfm-rubygem(hammer_cli_foreman) = 2.1.0 **************************************************************
    yum can be configured to try to resolve such errors by temporarily enabling
    disabled repos and searching for missing dependencies.
    To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf **************************************************************

Error: Package: tfm-rubygem-hammer_cli_katello-0.21-0.2.pre.master.20200204151350git3c82511.el7.noarch (katello)
Requires: tfm-rubygem(hammer_cli_foreman) < 1.0.0
Installing: tfm-rubygem-hammer_cli_foreman-2.1.0-0.1.pre.develop.20200311142946git1c5c94e.el7.noarch (foreman)
tfm-rubygem(hammer_cli_foreman) = 2.1.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

#2 Updated by Chris Roberts about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin
  • Status changed from New to Rejected

Hi,

The nightly repo is going to work and not work depending on when our upstream pipeline is passing. If you are wanting to try a stable build you can try Katello 3.15 RC or Katello 3.14. When the pipeline passes this will be resolved. Marking closed since not a bug.

#3 Updated by Jan Hutaƙ about 2 years ago

So where do we report issues like this? I agree it is probably not a bug in code, but it can be or it can be bug in spec file or in the process or... Where shall we report this next time? Was this problem fixed?

Also available in: Atom PDF